Bug 11945 - Quirksmode: No focus border on A and INPUT elements within a block with opacity
: Quirksmode: No focus border on A and INPUT elements within a block with opacity
Status: RESOLVED FIXED
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering
: 420+
: Macintosh Mac OS X 10.4
: P2 Normal
Assigned To: Nobody
http://www.quirksmode.org/bugreports/...
: HasReduction
Depends on:
Blocks: 9610
  Show dependency treegraph
 
Reported: 2006-12-23 05:50 PST by David Kilzer (:ddkilzer)
Modified: 2009-01-01 10:59 PST (History)
2 users (show)

See Also:


Attachments
Test page (3.11 KB, text/html)
2006-12-23 05:51 PST, David Kilzer (:ddkilzer)
no flags Details
reduced test case (385 bytes, text/html)
2007-11-10 12:43 PST, Brad
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Kilzer (:ddkilzer) 2006-12-23 05:50:32 PST
In Safari, <INPUT> and anchor (<A>) elements within a block that has opacity applied to it will not receive the treatment (blue border, by default) indicating that the user has put focus on that element (e.g. by tabbing). A workaround is provided to use the :focus pseudoclass on <INPUT> and anchor elements within the wrapping semi-opaque element to manually apply a style indicating the user has focused on the element.

Reported on 26 October 2006.

Test page: http://www.mularien.com/browser_bugs/safari_link_opacity_bug.html

Tested on locally-built debug build of WebKit r18401 with Safari 2.0.4 (419.3) on Mac OS X 10.4.8 (8N1037).
Comment 1 David Kilzer (:ddkilzer) 2006-12-23 05:51:45 PST
Created attachment 11984 [details]
Test page
Comment 2 mitz@webkit.org 2006-12-23 06:43:20 PST
Seems like an incremental repaint issue: note how forcing a repaint (e.g. by switching to a different tab and back) makes the focus ring appear where expected.
Comment 3 mitz@webkit.org 2007-08-18 09:27:26 PDT
I also think this might be a bug in Core Graphics in Tiger.
Comment 4 Brad 2007-11-10 12:43:21 PST
Created attachment 17174 [details]
reduced test case

First input is opacity:.9 and second is opacity:1.
Comment 5 Brad 2007-11-10 12:43:55 PST
I came across this same bug on my own, except I had the opacity set directly on the input itself (something the newer Webkit allows). Any opacity less than 1 will cause the focus glow to not draw.

I tested on a nightly download from 11/10/2007, build WebKit r27663 (on Tiger). 
Comment 6 Robert Blaut 2009-01-01 03:16:49 PST
I cannot reproduce the reported issue in WebKit 39524 on Mac OS X 10.5.6.
Comment 7 David Kilzer (:ddkilzer) 2009-01-01 10:53:53 PST
(In reply to comment #6)
> I cannot reproduce the reported issue in WebKit 39524 on Mac OS X 10.5.6.

The bisect-builds script reports:

Fails: r28505  Works: r28565

Resolving as fixed.

Comment 8 David Kilzer (:ddkilzer) 2009-01-01 10:57:16 PST
Broken in Safari 3.0.  Fixed in Safari 3.1 and later.

Comment 9 mitz@webkit.org 2009-01-01 10:59:09 PST
(In reply to comment #7)
> The bisect-builds script reports:
> 
> Fails: r28505  Works: r28565

Probably fixed in <http://trac.webkit.org/changeset/28523> then.