Bug 11944 - Quirksmode: Floats inside a scrolling div inside a table
: Quirksmode: Floats inside a scrolling div inside a table
Status: RESOLVED DUPLICATE of bug 5454
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering
: 420+
: Macintosh Mac OS X 10.4
: P2 Normal
Assigned To: Nobody
http://www.quirksmode.org/bugreports/...
: HasReduction
Depends on:
Blocks: 9610
  Show dependency treegraph
 
Reported: 2006-12-23 05:32 PST by David Kilzer (:ddkilzer)
Modified: 2006-12-23 07:06 PST (History)
0 users

See Also:


Attachments
Test page (1.90 KB, text/html)
2006-12-23 05:33 PST, David Kilzer (:ddkilzer)
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Kilzer (:ddkilzer) 2006-12-23 05:32:01 PST
Let's say you've some content inside a div with a defined size, which is inside a table. The div is set to overflow: auto, so any content that won't fit should scroll.

In Safari and Shiira, if the content inside the div is floated, the table height (not the div height) will expand to fit the height of the content inside the div.

Reported on 18 October 2006.

Test page: http://nightstand.org/random/safaribugtest.html

Tested on locally-built debug build of WebKit r18401 with Safari 2.0.4 (419.3)
on Mac OS X 10.4.8 (8N1037).
Comment 1 David Kilzer (:ddkilzer) 2006-12-23 05:33:13 PST
Created attachment 11983 [details]
Test page
Comment 2 David Kilzer (:ddkilzer) 2006-12-23 07:06:54 PST

*** This bug has been marked as a duplicate of 5454 ***