Bug 119391 - REGRESSION(FTL): Fix sh4 implementation of ctiVMThrowTrampolineSlowpath
Summary: REGRESSION(FTL): Fix sh4 implementation of ctiVMThrowTrampolineSlowpath
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-01 05:25 PDT by Julien Brianceau
Modified: 2013-08-01 06:27 PDT (History)
3 users (show)

See Also:


Attachments
ctiVMThrowTrampolineSlowpath fix for sh4 architecture. (1.65 KB, patch)
2013-08-01 05:54 PDT, Julien Brianceau
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Julien Brianceau 2013-08-01 05:25:38 PDT
ctiVMThrowTrampolineSlowpath implementation is not correct for sh4 architecture and crashes.
Comment 1 Julien Brianceau 2013-08-01 05:54:06 PDT
Created attachment 207919 [details]
ctiVMThrowTrampolineSlowpath fix for sh4 architecture.

According to the run-javascriptcore-tests script, sh4 port seems to be equivalent to what is was before FTL merge with this patch.
Comment 2 Csaba Osztrogonác 2013-08-01 06:03:48 PDT
Comment on attachment 207919 [details]
ctiVMThrowTrampolineSlowpath fix for sh4 architecture.

rs=me
Comment 3 WebKit Commit Bot 2013-08-01 06:27:46 PDT
Comment on attachment 207919 [details]
ctiVMThrowTrampolineSlowpath fix for sh4 architecture.

Clearing flags on attachment: 207919

Committed r153583: <http://trac.webkit.org/changeset/153583>
Comment 4 WebKit Commit Bot 2013-08-01 06:27:47 PDT
All reviewed patches have been landed.  Closing bug.