[Automake] Introduce libJSCBindings.la
Created attachment 207640 [details]
This basically extracts what might be the JSC bindings layer into its own library.
I think this is a good idea, but I find the name a bit confusing. It sounds to me like bindings for the JSC API instead of JSC DOM bindings. The GObject DOM bindings internal library is called libWebCoreDOM, which is not accurate either :-) What about libWebCoreJSDOM and libWebCoreGObjectDOM for example? This is a WebCore sub-library so I think it makes sense to have the libWebCore prefix. What do you think?
Yeah, it could use a better name:
- libWebCoreJSCDOMBindings and libWebCoreGObjectDOMBindings (long, but spot-on with the description),
- libJSCWebCoreDOMBindings and libGObjectWebCoreDOMBindings (again descriptive, compared to first proposal the 'JSC/GObject' part is switched with 'WebCore'),
- libJSCDOMBindings and libGObjectDOMBindings (loses the 'WebCore' part, if one thinks of it as a layer that's independent of WebCore),
- libJSCWebCoreBindings and libGObjectWebCoreBindings (loses the 'DOM' part, since technically.
So, basically, we should use whatever we agree on being the best and most descriptive combination of strings 'JSC', 'WebCore' and 'DOM'. :>
Building with disabled WK1, WK2 and SVG and with purged ccache, there's a ~1.8% increase in compilation time with this patch applied.
I'll pass this through, at least for now. Another library obviously just increases the build time, while the pros of introducing it are mostly purely of analytic nature.
I've filed bug #120232 about libWebCoreDOM needing a better name.