Bug 118724 - [GTK][Qt] After (r152685) svg/custom/xlink-prefix-in-attributes.html test fails.
Summary: [GTK][Qt] After (r152685) svg/custom/xlink-prefix-in-attributes.html test fails.
Status: RESOLVED DUPLICATE of bug 118701
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-16 02:32 PDT by Gábor Ábrahám
Modified: 2013-07-16 06:08 PDT (History)
5 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gábor Ábrahám 2013-07-16 02:32:08 PDT
After this patch, the updated svg/custom/xlink-prefix-in-attributes.html test fails.

diff:
--- /ramdisk/qt-linux-64-release/build/layout-test-results/svg/custom/xlink-prefix-in-attributes-expected.txt
+++ /ramdisk/qt-linux-64-release/build/layout-test-results/svg/custom/xlink-prefix-in-attributes-actual.txt
@@ -1,2 +1,2 @@
-<div xmlns="http://www.w3.org/1999/xhtml" id="target"> <div id="svgoutput"> </div><svg xmlns="http://www.w3.org/2000/svg" svg="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" width="200" height="200"><image width="20" height="20" xlink:href="resources/green-checker.png"/><image x="0" y="30" width="20" height="20" xlink:href="resources/green-checker.png"/></svg></div> <El xmlns:a="http://www.w3.org/1999/xlink" a:title="C" a:href="H"/>
+<div xmlns="http://www.w3.org/1999/xhtml" id="target"> <div id="svgoutput"> </div><svg xmlns="http://www.w3.org/2000/svg" svg="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" width="200" height="200"><image width="20" height="20" xlink:href="resources/green-checker.png"/><image x="0" y="30" width="20" height="20" xlink:href="resources/green-checker.png" xmlns="http://www.w3.org/1999/xlink"/></svg></div> <El xmlns:a="http://www.w3.org/1999/xlink" a:title="C" a:href="H"/>

I will skip this test now to paint the bot green.
Could you check it please?
Comment 1 Csaba Osztrogonác 2013-07-16 02:44:27 PDT
I think it isn't a bug, but the expected file should be updated similar to
https://trac.webkit.org/changeset/152685/trunk/LayoutTests/fast/dom/Element/getAttribute-check-case-sensitivity-expected.txt

The name of the original bug says:
XMLSerializer doesn't include namespaces on nodes in HTML documents
​https://bugs.webkit.org/show_bug.cgi?id=16496

So after this change, it is a normal behaviour to have
an additional string like: xmlns="http://www.w3.org/1999/xlink"

Rob, am I right?
Comment 2 Rob Buis 2013-07-16 06:03:36 PDT
Hi guys,

(In reply to comment #1)
> I think it isn't a bug, but the expected file should be updated similar to
> https://trac.webkit.org/changeset/152685/trunk/LayoutTests/fast/dom/Element/getAttribute-check-case-sensitivity-expected.txt
> 
> The name of the original bug says:
> XMLSerializer doesn't include namespaces on nodes in HTML documents
> ​https://bugs.webkit.org/show_bug.cgi?id=16496
> 
> So after this change, it is a normal behaviour to have
> an additional string like: xmlns="http://www.w3.org/1999/xlink"
> 
> Rob, am I right?

No, it is incorrect to write that out since it also puts the element in the xlink namespace. I have a fix up on bug 118701.
Comment 3 Csaba Osztrogonác 2013-07-16 06:08:30 PDT

*** This bug has been marked as a duplicate of bug 118701 ***