Bug 11870 - Bug 11866 caused layout test regression in fast/forms/input-value.html
Summary: Bug 11866 caused layout test regression in fast/forms/input-value.html
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Forms (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL:
Keywords: LayoutTestFailure
Depends on:
Blocks:
 
Reported: 2006-12-18 16:36 PST by David Kilzer (:ddkilzer)
Modified: 2006-12-18 18:40 PST (History)
3 users (show)

See Also:


Attachments
Patch with updated results. (1.42 KB, patch)
2006-12-18 18:05 PST, Mark Rowe (bdash)
beidson: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description David Kilzer (:ddkilzer) 2006-12-18 16:36:01 PST
The patch for Bug 11866 caused a layout test regression in fast/forms/input-value.html.

http://build.webkit.org/results/post-commit-powerpc-mac-os-x/4737/
Comment 1 David Kilzer (:ddkilzer) 2006-12-18 16:37:23 PST
Looks like the expected results just need to be updated.
Comment 2 Kirby White 2006-12-18 16:50:16 PST
If the goal is to match IE or Gecko, then it should have "after" in the second column for "hidden with value property changed", and this is a regression.  If the goal is to make sense, then I'd argue for "before", to match text and password fields.

I suppose trying to make sense is a bit quixotic here.
Comment 3 Kirby White 2006-12-18 17:30:38 PST
The two problems (the layout test failing now, and all three of those input types' attributes not doing what IE does) seem like separate issues to me.

What if I change the expected results to show "before" in the second column for hidden fields, just as they do for text and password fields, and then file a new bug to change the behavior of all three types to match what IE does?
Comment 4 Mark Rowe (bdash) 2006-12-18 17:43:36 PST
That sounds fine to me.
Comment 5 Mark Rowe (bdash) 2006-12-18 18:05:30 PST
Created attachment 11912 [details]
Patch with updated results.
Comment 6 Brady Eidson 2006-12-18 18:16:14 PST
Comment on attachment 11912 [details]
Patch with updated results.

Okay!
Comment 7 Mark Rowe (bdash) 2006-12-18 18:18:29 PST
Landed in r18292.  Kirby, can you please file the followup bug?
Comment 8 Kirby White 2006-12-18 18:40:39 PST
Filed as bug 11871.