Bug 11838 - Reopening SVG world map makes it blank
Summary: Reopening SVG world map makes it blank
Status: RESOLVED WONTFIX
Alias: None
Product: WebKit
Classification: Unclassified
Component: SVG (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL: http://apps.arcwebservices.com/svgvie...
Keywords: NeedsReduction
Depends on:
Blocks:
 
Reported: 2006-12-14 22:55 PST by Alexey Proskuryakov
Modified: 2012-02-01 21:30 PST (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexey Proskuryakov 2006-12-14 22:55:59 PST
Steps to reproduce:
1. Open http://apps.arcwebservices.com/svgviewer/map.html
2. After it loads, press Enter in the address bar.

Results: the second time, the map doesn't appear.

JS Console shows an exception (Null value) in this line, which casts a shadow on XMLHttpRequest:

        var importedNode = document.importNode(this.xmlRequest.responseXML.documentElement,true);
Comment 1 Alexey Proskuryakov 2006-12-15 09:34:15 PST
This is not 100% reproducible, but happens fairly often.

Further testing shows that responseXML is null because the response document is invalid, and it's invalid because the request is incorrect. 

$ curl -I "http://apps.arcwebservices.com/svgviewer/awslive?ds=ArcWeb:TA.Streets.US&sf=160000000&w=0&h=0&a=0&ocs=0&cmr=-100|10|0|0|160000000|0|9&dc=0|0"
HTTP/1.1 400 Invalid width ("w") parameter value: 0. The value should be a positive integer, not greater than 8192.

This now looks like a duplicate of bug 7722 to me.
Comment 2 Frank Y 2008-02-28 11:18:37 PST
100% reproducible on my nightly build.

Emptying the cache allows the page to reload, when pressing enter on the address bar.

After that the bug re-manifests.

Webkit:
Safari 3.0.4 5523.15 (nightly build for 2/28/2008)
OSX 10.5.2

Comment 3 Nikolas Zimmermann 2010-07-08 01:19:02 PDT
Changed component to SVG, so it shows up in my all-svg-bugs search.
Comment 4 Dirk Schulze 2011-05-18 10:27:24 PDT
The link is not valid anymore. Is there site to reproduce the problem?
Comment 5 Dirk Schulze 2012-02-01 21:30:51 PST
Closing the bug since we don't have a test to reproduce the issue :(