Bug 118279 - Make KURL::hasPath private
Summary: Make KURL::hasPath private
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Zan Dobersek
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-01 22:22 PDT by Zan Dobersek
Modified: 2013-07-24 12:03 PDT (History)
5 users (show)

See Also:


Attachments
Patch (2.30 KB, patch)
2013-07-01 22:28 PDT, Zan Dobersek
no flags Details | Formatted Diff | Diff
Patch (3.74 KB, patch)
2013-07-01 23:02 PDT, Zan Dobersek
no flags Details | Formatted Diff | Diff
Patch (3.45 KB, patch)
2013-07-23 15:34 PDT, Zan Dobersek
darin: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Zan Dobersek 2013-07-01 22:22:50 PDT
Remove KURL::hasPath
Comment 1 Zan Dobersek 2013-07-01 22:28:05 PDT
Created attachment 205864 [details]
Patch
Comment 2 EFL EWS Bot 2013-07-01 22:59:39 PDT
Comment on attachment 205864 [details]
Patch

Attachment 205864 [details] did not pass efl-wk2-ews (efl-wk2):
Output: http://webkit-queues.appspot.com/results/1017200
Comment 3 Zan Dobersek 2013-07-01 23:02:58 PDT
Created attachment 205869 [details]
Patch
Comment 4 Chris Dumez 2013-07-02 00:07:17 PDT
Comment on attachment 205869 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=205869&action=review

> Source/WebCore/platform/KURL.cpp:-559
> -    if (!hasPath())

Why do we want to remove hasPath()? I find it is much more readable than comparing positions.
Comment 5 Darin Adler 2013-07-02 12:09:23 PDT
Comment on attachment 205869 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=205869&action=review

> Source/WebCore/ChangeLog:9
> +        Remove the KURL::hasPath method. It was not used anywhere but KURL::lastPathComponent where
> +        it's replaced by comparing positions of the ends of the port and path components.

This seems like a good rationale to make hasPath private instead of public, but possibly not sufficient reason to remove it entirely.
Comment 6 Zan Dobersek 2013-07-03 00:02:17 PDT
OK, I'll make the method private.
Comment 7 Zan Dobersek 2013-07-23 15:34:40 PDT
Created attachment 207353 [details]
Patch
Comment 8 Darin Adler 2013-07-24 10:14:43 PDT
Comment on attachment 207353 [details]
Patch

The three sentence comment for this private function used in just one or two places seems like overkill.
Comment 9 Zan Dobersek 2013-07-24 12:02:13 PDT
Committed r153093: <http://trac.webkit.org/changeset/153093>
Comment 10 Zan Dobersek 2013-07-24 12:03:05 PDT
Removed the comments prior to landing.