Steps to reproduce:
1. Go to daringfireball.net on non-HiDPI display.
2. Click on any link on the page e.g. "Projects".
3. Move the window to HiDPI display.
4. Click the back button.
Created attachment 205750 [details]
Comment on attachment 205750 [details]
View in context: https://bugs.webkit.org/attachment.cgi?id=205750&action=review
> + bool m_needsDeviceScaleChanged;
I don't really like the "needs XYZ changed" naming (it's really 'needs to *call* XYZChanged', or maybe needsDeviceScaleUpdate or something), but there's already one like that here :|
Thanks, Tim! I gave it some thought but was unable to think of a better name. I do agree it's not great. I will keep thinking on it.