During the build there are a few warning reporting unused variable/parameter in the curl parts.
Created attachment 205459 [details] patch This should get rid of the warnings.
Attachment 205459 [details] did not pass style-queue: Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/WebCore/ChangeLog', u'Source/WebCore/platform/network/curl/CredentialStorageCurl.cpp', u'Source/WebCore/platform/network/curl/DNSCurl.cpp', u'Source/WebCore/platform/network/curl/ResourceHandleManager.cpp']" exit_code: 1 Source/WebCore/platform/network/curl/ResourceHandleManager.cpp:118: curl_lock_callback is incorrectly named. Don't use underscores in your identifier names. [readability/naming/underscores] [4] Source/WebCore/platform/network/curl/ResourceHandleManager.cpp:124: curl_unlock_callback is incorrectly named. Don't use underscores in your identifier names. [readability/naming/underscores] [4] Total errors found: 2 in 4 files If any of these errors are false positives, please file a bug against check-webkit-style.
(In reply to comment #2) > Attachment 205459 [details] did not pass style-queue: > > Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/WebCore/ChangeLog', u'Source/WebCore/platform/network/curl/CredentialStorageCurl.cpp', u'Source/WebCore/platform/network/curl/DNSCurl.cpp', u'Source/WebCore/platform/network/curl/ResourceHandleManager.cpp']" exit_code: 1 > Source/WebCore/platform/network/curl/ResourceHandleManager.cpp:118: curl_lock_callback is incorrectly named. Don't use underscores in your identifier names. [readability/naming/underscores] [4] > Source/WebCore/platform/network/curl/ResourceHandleManager.cpp:124: curl_unlock_callback is incorrectly named. Don't use underscores in your identifier names. [readability/naming/underscores] [4] > Total errors found: 2 in 4 files > > > If any of these errors are false positives, please file a bug against check-webkit-style. I don't think we should address this in this patch.
Comment on attachment 205459 [details] patch View in context: https://bugs.webkit.org/attachment.cgi?id=205459&action=review > Source/WebCore/ChangeLog:7 > + Missing changelog.
Created attachment 205580 [details] patch v2 now with "pretty changelog"
Attachment 205580 [details] did not pass style-queue: Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/WebCore/ChangeLog', u'Source/WebCore/platform/network/curl/CredentialStorageCurl.cpp', u'Source/WebCore/platform/network/curl/DNSCurl.cpp', u'Source/WebCore/platform/network/curl/ResourceHandleManager.cpp']" exit_code: 1 Source/WebCore/platform/network/curl/ResourceHandleManager.cpp:118: curl_lock_callback is incorrectly named. Don't use underscores in your identifier names. [readability/naming/underscores] [4] Source/WebCore/platform/network/curl/ResourceHandleManager.cpp:124: curl_unlock_callback is incorrectly named. Don't use underscores in your identifier names. [readability/naming/underscores] [4] Total errors found: 2 in 4 files If any of these errors are false positives, please file a bug against check-webkit-style.
Comment on attachment 205580 [details] patch v2 ok, r=me.
Comment on attachment 205580 [details] patch v2 Clearing flags on attachment: 205580 Committed r152087: <http://trac.webkit.org/changeset/152087>
All reviewed patches have been landed. Closing bug.