Bug 11804 - Object should submit (name attribute on <object>)
Summary: Object should submit (name attribute on <object>)
Status: RESOLVED DUPLICATE of bug 13061
Alias: None
Product: WebKit
Classification: Unclassified
Component: Plug-ins (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL: http://misc.xstandard.com/apple/javas...
Keywords:
Depends on:
Blocks:
 
Reported: 2006-12-11 08:46 PST by Vlad Alexander
Modified: 2007-03-21 13:39 PDT (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vlad Alexander 2006-12-11 08:46:56 PST
The <object> element should send data to the server just like any other form control when the "name" attribute is present. For example:

<object type="application/x-xstandard" name="editor1" width="100%" height="300"></object>

Test case:
http://misc.xstandard.com/apple/javascriptfree.asp

For Netscape plug-in API implementation please see:
https://bugzilla.mozilla.org/show_bug.cgi?id=188938

We are a browser plug-in vendors and would very much would like to use this construct which is already supported by IE, FF and Opera.
Comment 1 Alexey Proskuryakov 2007-03-21 13:39:32 PDT
This bug was filed earlier, but bug 13061 already contains some information helpful for implementation, so marking this one as a duplicate.

*** This bug has been marked as a duplicate of 13061 ***