Bug 117909 - Can't type tilde in web view
Summary: Can't type tilde in web view
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-22 06:36 PDT by alexander.wilms
Modified: 2013-09-09 09:00 PDT (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description alexander.wilms 2013-06-22 06:36:13 PDT
I'm using Midori, A WebkitGtk-based browser.

I reported this bug, where I was told to report it to Webkit: https://bugs.launchpad.net/midori/+bug/1032973

about:version contents:

Version numbers in brackets show the version used at runtime.


Command line midori
Midori 0.5.2~r6207 ((null))
GTK+ 3.4.2 (3.4.2)	Glib 2.32.3 (2.32.3)
WebKitGTK+ 1.8.3 (1.8.3)	libSoup 2.38.1
cairo 1.10.2 (1.10.2)	libnotify 0.7.5
gcr No	granite 0.2
single instance libunique 3.0.2
Platform X11; Linux x86_64
Identification Mozilla/5.0 (X11; Linux) AppleWebKit/535.22 (KHTML, like Gecko) Chrome/18.0.1025.133 Safari/535.22 Midori/0.5
Video Formats H264 [x]   Ogg Theora [x]   WebM [x]
Comment 1 Alberto Garcia 2013-07-01 09:28:15 PDT
I'm not sure how this can be a WebKit problem.

Can you give a few more details?

- What's your keyboard layout?
- How do you type the tilde?
- Does it fail only in the URL bar or also in other text fields?
- Does it happen in other GTK+ applications?

Thanks!
Comment 2 Alberto Garcia 2013-07-01 09:38:20 PDT
Sorry, I was reading too fast. So you can actually type it in the URL bar.

Do you have problems with accents or other symbols?
Comment 3 alexander.wilms 2013-07-01 11:03:11 PDT
No, e.g. é or ê can be typed without an issue
Comment 4 Sergio Villar Senin 2013-07-04 04:47:38 PDT
(In reply to comment #3)
> No, e.g. é or ê can be typed without an issue

Does not look like a WebKit bug, seems a problem with your environment
Comment 5 Alberto Garcia 2013-09-09 03:18:08 PDT
I also can't reproduce that problem here, I tried with Midori 0.4.3, GtkLauncher and MiniBrowser. It works fine in all cases.

Do you still have that problem? Can you try with a different version of Midori, or some other webkit-based browser?
Comment 6 alexander.wilms 2013-09-09 09:00:45 PDT
I tried Epiphany on the same system with the same result. Typing ~ works in Firefox, though.

The error did not occur using Midori 0.5.5 on Ubuntu 13.04

Command line midori
Midori midori-granite-0.5.5+r6390 ((null))
GTK+ 3.6.4 (3.6.4)	Glib 2.36.0 (2.36.0)
WebKitGTK+ 1.10.2 (1.10.2)	libSoup 2.40.3
cairo 1.12.14 (1.12.14)	libnotify 0.7.5
gcr No	granite 0.2.2
Platform X11; Linux i686
Identification Mozilla/5.0 (X11; Linux) AppleWebKit/537.6 (KHTML, like Gecko) Chrome/18.0.1025.133 Safari/537.6 Midori/0.5
Video Formats H264 [x]   Ogg Theora [x]   WebM [x]

Looks like it's resoled now