Bug 117649 - [GTK][WK2] adding subtitles (with toggle button) on html videos
Summary: [GTK][WK2] adding subtitles (with toggle button) on html videos
Status: RESOLVED DUPLICATE of bug 117008
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on: 117177
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-14 12:07 PDT by Danilo Cesar Lemes de Paula
Modified: 2013-08-18 05:52 PDT (History)
12 users (show)

See Also:


Attachments
Patch (5.25 KB, patch)
2013-06-14 12:08 PDT, Danilo Cesar Lemes de Paula
no flags Details | Formatted Diff | Diff
Patch (5.29 KB, patch)
2013-06-14 12:10 PDT, Danilo Cesar Lemes de Paula
no flags Details | Formatted Diff | Diff
Patch (5.89 KB, text/plain)
2013-06-17 05:45 PDT, Danilo Cesar Lemes de Paula
buildbot: commit-queue-
Details
Archive of layout-test-results from webkit-ews-01 for mac-mountainlion (501.48 KB, application/zip)
2013-06-17 07:05 PDT, Build Bot
no flags Details
Archive of layout-test-results from webkit-ews-03 for mac-mountainlion (578.15 KB, application/zip)
2013-06-17 07:50 PDT, Build Bot
no flags Details
Archive of layout-test-results from webkit-ews-15 for mac-mountainlion-wk2 (768.26 KB, application/zip)
2013-06-17 11:02 PDT, Build Bot
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Danilo Cesar Lemes de Paula 2013-06-14 12:07:48 PDT
[GTK][WK2] adding subtitles (with toggle button) on html videos
Comment 1 Danilo Cesar Lemes de Paula 2013-06-14 12:08:08 PDT
Created attachment 204728 [details]
Patch
Comment 2 WebKit Commit Bot 2013-06-14 12:10:12 PDT
Thanks for the patch. If this patch contains new public API please make sure it follows the guidelines for new WebKit2 GTK+ API. See http://trac.webkit.org/wiki/WebKitGTK/AddingNewWebKit2API
Comment 3 Danilo Cesar Lemes de Paula 2013-06-14 12:10:13 PDT
Created attachment 204729 [details]
Patch
Comment 4 Carlos Garcia Campos 2013-06-16 23:51:39 PDT
Comment on attachment 204729 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=204729&action=review

Thanks for the patch.

> Source/WebKit2/UIProcess/API/gtk/WebKitSettings.cpp:1163
> +    settings->priv->preferences->setShouldDisplaySubtitles(TRUE);

It should be true, not TRUE. If we want to enable this unconditionally, this is not the place to do it. You should change the default value of the setting for the GTK platform in Shared/WebPreferencesStore.h
Comment 5 Danilo Cesar Lemes de Paula 2013-06-17 05:45:07 PDT
Created attachment 204812 [details]
Patch
Comment 6 Danilo Cesar Lemes de Paula 2013-06-17 05:49:48 PDT
Comment on attachment 204812 [details]
Patch

wrong file here...
Comment 7 Build Bot 2013-06-17 07:05:05 PDT
Comment on attachment 204812 [details]
Patch

Attachment 204812 [details] did not pass mac-ews (mac):
Output: http://webkit-queues.appspot.com/results/929029

New failing tests:
media/video-controls-captions-trackmenu-hide-on-click.html
fast/repaint/table-cell-collapsed-border-scroll.html
media/video-controls-captions-trackmenu-hide-on-click-outside.html
Comment 8 Build Bot 2013-06-17 07:05:08 PDT
Created attachment 204820 [details]
Archive of layout-test-results from webkit-ews-01 for mac-mountainlion

The attached test failures were seen while running run-webkit-tests on the mac-ews.
Bot: webkit-ews-01  Port: mac-mountainlion  Platform: Mac OS X 10.8.3
Comment 9 Build Bot 2013-06-17 07:50:24 PDT
Comment on attachment 204812 [details]
Patch

Attachment 204812 [details] did not pass mac-ews (mac):
Output: http://webkit-queues.appspot.com/results/895141

New failing tests:
media/video-controls-captions-trackmenu-hide-on-click.html
fast/repaint/table-cell-collapsed-border-scroll.html
media/video-controls-captions-trackmenu-hide-on-click-outside.html
Comment 10 Build Bot 2013-06-17 07:50:28 PDT
Created attachment 204822 [details]
Archive of layout-test-results from webkit-ews-03 for mac-mountainlion

The attached test failures were seen while running run-webkit-tests on the mac-ews.
Bot: webkit-ews-03  Port: mac-mountainlion  Platform: Mac OS X 10.8.3
Comment 11 Build Bot 2013-06-17 11:02:50 PDT
Comment on attachment 204812 [details]
Patch

Attachment 204812 [details] did not pass mac-wk2-ews (mac-wk2):
Output: http://webkit-queues.appspot.com/results/857391

New failing tests:
media/video-controls-captions-trackmenu-hide-on-click.html
media/video-controls-captions-trackmenu-hide-on-click-outside.html
Comment 12 Build Bot 2013-06-17 11:02:53 PDT
Created attachment 204839 [details]
Archive of layout-test-results from webkit-ews-15 for mac-mountainlion-wk2

The attached test failures were seen while running run-webkit-tests on the mac-wk2-ews.
Bot: webkit-ews-15  Port: mac-mountainlion-wk2  Platform: Mac OS X 10.8.3
Comment 13 Danilo Cesar Lemes de Paula 2013-08-18 05:52:23 PDT
Subtitles support on webkitgtk is being handled by https://bugs.webkit.org/show_bug.cgi?id=117008

*** This bug has been marked as a duplicate of bug 117008 ***