Bug 117308 - [CSS Shapes] Rename updateLineBoundariesForExclusions to updateLineBoundariesForShapes
Summary: [CSS Shapes] Rename updateLineBoundariesForExclusions to updateLineBoundaries...
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Zoltan Horvath
Depends on:
Blocks: 89256
  Show dependency treegraph
Reported: 2013-06-06 10:33 PDT by Zoltan Horvath
Modified: 2013-06-06 15:49 PDT (History)
3 users (show)

See Also:

proposed patch (3.77 KB, patch)
2013-06-06 10:36 PDT, Zoltan Horvath
achicu: review+
achicu: commit-queue-
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Zoltan Horvath 2013-06-06 10:33:04 PDT
We have a standalone specification for CSS Shapes now: ​http://dev.w3.org/csswg/css-shapes/
so this change renames updateLineBoundariesForExclusions to updateLineBoundariesForShapes.
Comment 1 Zoltan Horvath 2013-06-06 10:36:23 PDT
Created attachment 203949 [details]
proposed patch
Comment 2 Alexandru Chiculita 2013-06-06 14:53:14 PDT
Comment on attachment 203949 [details]
proposed patch

View in context: https://bugs.webkit.org/attachment.cgi?id=203949&action=review

> Source/WebCore/rendering/RenderBlock.h:1087
> +    void updateLineBoundariesForShapes(ExclusionShapeInsideInfo*, LayoutUnit&, LineLayoutState&, bool&);

nit: the name is a little confusing. what about updateShapeAndSegmentsForCurrentLine ?
Comment 3 Zoltan Horvath 2013-06-06 15:49:22 PDT
(In reply to comment #2)
> nit: the name is a little confusing. what about updateShapeAndSegmentsForCurrentLine ?

Thanks for the review!

Updated and landed in: http://trac.webkit.org/changeset/151295