Bug 11700 - DumpRenderTree dumpAsText() should handle child frames
Summary: DumpRenderTree dumpAsText() should handle child frames
Status: RESOLVED DUPLICATE of bug 11090
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P3 Minor
Assignee: Nobody
URL:
Keywords:
: 11701 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-11-27 17:33 PST by Kevin McCullough
Modified: 2006-12-14 22:44 PST (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin McCullough 2006-11-27 17:33:43 PST
* SUMMARY
When a layout test calls dumpAsText(), it expects it's text to be written out, but dumpAsText() does not take into account child frames.

* STEPS TO REPRODUCE
1. Look at targeted-frame-submission.html in LayoutTests/fast/forms
2. Notice that the DumpRenderTree() lines are commented out.  If they were uncommented the output would not include the word SUCCESS in the iframe even thought the submission was a success.
Comment 1 Alexey Proskuryakov 2006-11-27 21:19:34 PST
*** Bug 11701 has been marked as a duplicate of this bug. ***
Comment 2 Alexey Proskuryakov 2006-12-14 22:44:00 PST

*** This bug has been marked as a duplicate of 11090 ***