Bug 11676 - Callback bug?
Summary: Callback bug?
Status: RESOLVED INVALID
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit API (show other bugs)
Version: 419.x
Hardware: Macintosh Intel OS X 10.4
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-11-22 02:54 PST by daniele margutti
Modified: 2006-11-23 09:19 PST (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description daniele margutti 2006-11-22 02:54:36 PST
This is a crash log from an app of mine.
I can't reproduce this error, it happends without an evident reason.

This is the log:
http://www.box.net/public/catbvhyepk
Comment 1 Alexey Proskuryakov 2006-11-22 05:09:26 PST
Can you reproduce this problem when testting with a nightly WebKit build? Pease see <http://developer.apple.com/opensource/internet/nightlywebkit.html> for the instructions.

---------------------------------------------------------------
Thread 0 Crashed:?0 com.apple.WebCore 0?952e3138 KWQValueListImpl::copyOnWrite() + 16?1 com.apple.WebCore 0?952e7eb0 KWQValueListImpl::begin() + 18?2 com.apple.WebCore 0?95507351 QValueList::begin() + 17?3 com.apple.WebCore 0?95410e87 KHTMLPart::checkCompleted() + 31?4 com.apple.WebCore 0?953197ab KWQSignal::call(khtml::DocLoader*, khtml::CachedObject*) const + 115?5 com.apple.WebCore 0?95323590 khtml::Loader::slotFinished(KIO::Job*, NSData*) + 346?6 com.apple.WebCore 0?9546df59 KWQSignal::callWithData(KIO::Job*, NSData*) const + 115?7 com.apple.WebCore 0?95323425 KIO::TransferJob::emitResult(NSData*) + 37?8 com.apple.WebCore 0?953233d0 -[KWQResourceLoader finishJobAndHandle:] + 76?9 com.apple.WebKit 0?95153522 -[WebSubresourceClient didFinishLoading] + 78?10 com.apple.WebKit 0?95152669 -[WebBaseResourceHandleDelegate connectionDidFinishLoading:] + 40?11 com.apple.Foundation 0?92651e00 -[NSURLConnection(NSURLConnectionInternal) _sendDidFinishLoadingCallback] + 176?12 com.apple.Foundation 0?9264fea5 -[NSURLConnection(NSURLConnectionInternal) _sendCallbacks] + 748?13 com.apple.Foundation 0?9264fb41 _sendCallbacks + 201?14 com.apple.CoreFoundation 0?90828fd2 CFRunLoopRunSpecific + 1213?15 com.apple.CoreFoundation 0?90828b0e CFRunLoopRunInMode + 61?16 com.apple.HIToolbox 0?92dc7bef RunCurrentEventLoopInMode + 285?17 com.apple.HIToolbox 0?92dc72fd ReceiveNextEventCommon + 385?18 com.apple.HIToolbox 0?92dc7154 BlockUntilNextEventMatchingListInMode + 81?19 com.apple.AppKit 0?9326c465 _DPSNextEvent + 572?20 com.apple.AppKit 0?9326c056 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 137?21 com.apple.AppKit 0?93265ddb -[NSApplication run] + 512?22 com.apple.AppKit 0?93259d2f NSApplicationMain + 573?23 com.malcom-mac.nemo 0?00002f5a _start + 216?24 com.malcom-mac.nemo 0?00002e81 start + 41
Comment 2 daniele margutti 2006-11-23 09:18:39 PST
ok seems to be solved. It was an error with XSL transformation i think.