Bug 11673 - REGRESSION(r14067): Dojo examples don't load in iframe
Summary: REGRESSION(r14067): Dojo examples don't load in iframe
Status: RESOLVED WORKSFORME
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P1 Normal
Assignee: Nobody
URL: http://dojotoolkit.org/
Keywords: InRadar, NeedsReduction, Regression
Depends on:
Blocks: 13846
  Show dependency treegraph
 
Reported: 2006-11-21 21:34 PST by Matt Lilek
Modified: 2007-05-23 10:36 PDT (History)
0 users

See Also:


Attachments
start on a reduction (108.83 KB, text/html)
2007-02-22 19:53 PST, Maciej Stachowiak
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matt Lilek 2006-11-21 21:34:31 PST
The examples at the provided url (click the "See it in Action" tab for the examples) don't load in the iframes on the example page, but loading them in a new tab/window loads them fine (http://dojotoolkit.org/dojo/demos/widget/Mail.html).  Appears to be a side effect of the loader refactoring.
Comment 1 Joost de Valk (AlthA) 2007-01-19 06:42:38 PST
Works for me... Reporter: please check in latest nightly, and reopen if it still doesn't work for you.
Comment 2 Matt Lilek 2007-01-19 11:13:54 PST
Reopening as this is still an issue.

Load the website, click "see it in action", click "Demo Applications" and finally "View Demo" under the Mail example.  Firefox loads it fine, WebKit doesn't.  I get a number of these errors printed to the console in my debug build of r18973:

ERROR: unimplemented propertyID: 46
(/Users/matt/Code/WebKit/WebCore/css/CSSComputedStyleDeclaration.cpp:1474 WTF::PassRefPtr<WebCore::CSSValue> WebCore::CSSComputedStyleDeclaration::getPropertyCSSValue(int, WebCore::EUpdateLayout) const)
Comment 3 Stephanie Lewis 2007-01-22 18:01:25 PST
In Radar<rdar://problem/4947072>
Comment 4 Darin Adler 2007-01-26 01:58:12 PST
As I suspected, implementing computed style for box-sizing got rid fo the log message but didn't make the Dojo examples work.

The actual problem does seem to be something related to frame loading.
Comment 5 Maciej Stachowiak 2007-02-12 23:47:33 PST
I'm not sure this has anything to do with loading. If you look at the frame source for the example frame, or inspect it in the web inspector, it looks like the elements are all there, and have proper style and layout metrics. But nothing seems to paint!
Comment 6 Matt Lilek 2007-02-13 07:53:19 PST
I was just looking at this last night.  The reason we're not painting is because they're setting the width of the example iframe's parent div to 0 in ToT.  I'm not sure if thats an intermediate step that happens on all browsers but is then changed and that isn't happening on ToT (spoofing as another browser doesn't do anything) or what as reducing the Dojo code is, erm, "fun"...
Comment 7 Maciej Stachowiak 2007-02-19 22:42:38 PST
Works in r13060.
Comment 8 Matt Lilek 2007-02-19 22:45:51 PST
Whatever caused this happened between r14055 and r14071.
Comment 9 Maciej Stachowiak 2007-02-20 02:32:48 PST
I definitively tracked this down to r14067. It seems like that patch should only have affected computed margin and padding; not clear why it results in a width of 0px.
Comment 10 Maciej Stachowiak 2007-02-22 19:53:11 PST
Created attachment 13337 [details]
start on a reduction

Here's a start on a reduction, all in one file. It's still huge. I think I may have also over-reduced this, ass adding back the iframe I took out does result in the frame showing up now, although the height of its containing div is still wrong.
Comment 11 Maciej Stachowiak 2007-02-22 19:59:15 PST
Indeed, my reduction still fails with the revision before the regression, so I think it is just an unrelated Safari/Firefox behavior difference.
Comment 12 Maciej Stachowiak 2007-02-23 00:30:19 PST
Revision that regressed this is http://trac.webkit.org/projects/webkit/changeset/14067
Comment 13 Maciej Stachowiak 2007-02-25 16:22:58 PST
I talked to Alex Russel of Dojo fame about this, and he pointed out that soon a new version of the Dojo site will be launching. The preview version does't show this bug with ToT WebKit, but ironically, it fails in a similar way with Safari 2.0.4.
Comment 14 Matt Lilek 2007-04-06 11:01:50 PDT
Dojo updated their website and this bug doesn't show anymore.  Closing since we could never figure out exactly what caused it.