Bug 116451 - Crash in convertMainResourceLoadToDownload when downloading file by option-return
Summary: Crash in convertMainResourceLoadToDownload when downloading file by option-re...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel OS X 10.8
: P2 Normal
Assignee: Anders Carlsson
URL:
Keywords: InRadar
: 114672 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-05-20 11:15 PDT by d235j.1
Modified: 2013-06-16 21:23 PDT (History)
5 users (show)

See Also:


Attachments
Crash log (52.61 KB, text/plain)
2013-05-20 11:15 PDT, d235j.1
no flags Details
Crash of debug WebKit build (61.68 KB, text/plain)
2013-05-23 11:08 PDT, d235j.1
no flags Details
Patch (9.03 KB, patch)
2013-05-23 12:46 PDT, Anders Carlsson
kling: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description d235j.1 2013-05-20 11:15:40 PDT
Created attachment 202296 [details]
Crash log

When downloading a loaded page by pressing option-return in the address bar, WebKit may crash with the attached error log.
This happens mainly when downloading PDF files, since this is my most common use case, but I believe I've seen it with images and HTML as well.
I am using the built-in Apple PDF viewer, not the Adobe Reader plugin, so this should not be a plug-in related issue.
Comment 1 d235j.1 2013-05-23 11:08:50 PDT
Created attachment 202729 [details]
Crash of debug WebKit build
Comment 2 d235j.1 2013-05-23 11:09:04 PDT
I've attached a crash log of a debug build of WebKit, which should be way more useful.
Comment 3 Anders Carlsson 2013-05-23 12:43:08 PDT
<rdar://problem/13895327>
Comment 4 Anders Carlsson 2013-05-23 12:46:38 PDT
Created attachment 202735 [details]
Patch
Comment 5 Andreas Kling 2013-05-23 13:06:15 PDT
Comment on attachment 202735 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=202735&action=review

r=me

> Source/WebKit2/NetworkProcess/NetworkConnectionToWebProcess.cpp:181
> +    if (!mainResourceLoadIdentifier) {
> +        NetworkProcess::shared().downloadManager().startDownload(downloadID, request);
> +        return;
> +    }

I think this could use a comment about what mainResourceLoadIdentifier=0 means.
Comment 6 Anders Carlsson 2013-05-23 13:07:55 PDT
Committed r150609: <http://trac.webkit.org/changeset/150609>
Comment 7 Mary Wu 2013-06-16 21:23:04 PDT
*** Bug 114672 has been marked as a duplicate of this bug. ***