Bug 116316 - [BlackBerry] ImageBlackBerry: add missing BlendMode parameter
Summary: [BlackBerry] ImageBlackBerry: add missing BlendMode parameter
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit BlackBerry (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks: 111729
  Show dependency treegraph
 
Reported: 2013-05-17 08:06 PDT by Alberto Garcia
Modified: 2013-05-17 08:59 PDT (History)
3 users (show)

See Also:


Attachments
Patch (1.76 KB, patch)
2013-05-17 08:08 PDT, Alberto Garcia
no flags Details | Formatted Diff | Diff
Patch (1.92 KB, patch)
2013-05-17 08:19 PDT, Alberto Garcia
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alberto Garcia 2013-05-17 08:06:29 PDT
When the new BitmapImage::draw() method was added in r147110 it didn't include the BlendMode parameter, which has been there since r137011.
Comment 1 Alberto Garcia 2013-05-17 08:08:16 PDT
Created attachment 202089 [details]
Patch
Comment 2 Carlos Garcia Campos 2013-05-17 08:15:11 PDT
Comment on attachment 202089 [details]
Patch

Please, include the first comment of the bug in the changelog too
Comment 3 Alberto Garcia 2013-05-17 08:19:03 PDT
Created attachment 202090 [details]
Patch

So be it.
Comment 4 WebKit Commit Bot 2013-05-17 08:59:34 PDT
Comment on attachment 202090 [details]
Patch

Clearing flags on attachment: 202090

Committed r150262: <http://trac.webkit.org/changeset/150262>
Comment 5 WebKit Commit Bot 2013-05-17 08:59:36 PDT
All reviewed patches have been landed.  Closing bug.