Bug 11621 - REGRESSION (Native slider): slider thumb not updated when the mouse is dragged/released out of range
Summary: REGRESSION (Native slider): slider thumb not updated when the mouse is dragge...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Forms (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P1 Normal
Assignee: Nobody
URL:
Keywords: InRadar, Regression
Depends on:
Blocks:
 
Reported: 2006-11-16 16:07 PST by mitz
Modified: 2007-02-10 17:11 PST (History)
1 user (show)

See Also:


Attachments
Update the thumb's layer's position (1.22 KB, patch)
2007-02-10 03:27 PST, mitz
aroben: review+
Details | Formatted Diff | Diff
Automated "manual" test (1005 bytes, text/html)
2007-02-10 03:28 PST, mitz
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description mitz 2006-11-16 16:07:15 PST
If you grab a slider's thumb and drag it fast enough (on a machine that's slow enough) past the edge of the slider, it doesn't move all the way to the edge, and when you release the mouse (still out of the slider's range), the thumb maintains its "pressed" appearance (this is true whenever you release the thumb with while the mouse is "out of range"). Forcing a repaint fixes thumb position and appearance.

Another bug that is probably related is that when you click the slider track and hold still, the thumb gets the "pressed" appearance but doesn't jump to where you clicked. Thumb painting seems to be always "lagging by one event".
Comment 1 Mark Rowe (bdash) 2007-01-28 16:08:36 PST
<rdar://problem/4960133>
Comment 2 mitz 2007-02-10 03:27:38 PST
Created attachment 13101 [details]
Update the thumb's layer's position
Comment 3 mitz 2007-02-10 03:28:30 PST
Created attachment 13102 [details]
Automated "manual" test

This test works in Safari but not in DumpRenderTree.
Comment 4 Adam Roben (:aroben) 2007-02-10 03:32:00 PST
Comment on attachment 13101 [details]
Update the thumb's layer's position

r=me
Comment 5 David Kilzer (:ddkilzer) 2007-02-10 17:11:43 PST
Committed revision 19556.

Added the automated "manual" test to WebCore/manual-tests.