Bug 11615 - Regression: Problem with switching to Webkit app with Shockwave on page
Summary: Regression: Problem with switching to Webkit app with Shockwave on page
Status: RESOLVED WONTFIX
Alias: None
Product: WebKit
Classification: Unclassified
Component: Plug-ins (show other bugs)
Version: 420+
Hardware: Mac (PowerPC) OS X 10.4
: P2 Normal
Assignee: Nobody
URL: http://www.lingoworkshop.com/Testzone...
Keywords: Regression
Depends on:
Blocks:
 
Reported: 2006-11-16 04:56 PST by Kevin M. Dean
Modified: 2022-06-27 15:32 PDT (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin M. Dean 2006-11-16 04:56:43 PST
On pages that have the Shockwave plugin, I'm finding that clicking from one app window (ex: from Apple Mail) to the Webkit window in the content area to not be working consistently. On the above link, I have my Mail window open in center of the screen so I can see the site on either side and below. If I click to the right or below, it doesn't switch. If I click immediately to the left it doesn't switch, but if I keep trying until I reach the upper left corner of the site I eventually find a spot that works. If I switch tabs to another regular page, clicking works fine.

Here's another test page that has a similar problem, but the sweet spot for the clicks to work is placed differently. Seems that it could be related to the position of the embedded plugin content itself.

http://www.adobe.com/shockwave/welcome/

Works fine in Safari (except my initial link doesn't work in Safari due to another bug), so use Adobe link for Safari testing.
Comment 1 Kevin M. Dean 2006-11-16 04:59:21 PST
One additional note I just found. It appears that clicking multiple times in the previous dead areas will eventually cause the app to switch. You can even see some of the window elements change as if you brought it to the foreground even though the app hasn't switched yet.
Comment 2 Ahmad Saleem 2022-06-27 15:29:32 PDT
NPAPI and Webkit Plugins are not supported any more. Can this be marked as "RESOLVED WONTFIX"? Thanks!