Bug 116068 - No platform ever overrides RenderTheme::supportsCalendarPicker
Summary: No platform ever overrides RenderTheme::supportsCalendarPicker
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore Misc. (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-13 16:09 PDT by Daker Fernandes Pinheiro
Modified: 2013-05-15 06:01 PDT (History)
3 users (show)

See Also:


Attachments
Remove RenderTheme::supportsCalendarPicker (5.31 KB, patch)
2013-05-13 16:11 PDT, Daker Fernandes Pinheiro
no flags Details | Formatted Diff | Diff
Remove RenderTheme::supportsCalendarPicker (4.57 KB, patch)
2013-05-13 16:13 PDT, Daker Fernandes Pinheiro
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Daker Fernandes Pinheiro 2013-05-13 16:09:25 PDT
The method RenderTheme::supportsCalendarPicker always return false because no one ever overrides it.
Comment 1 Daker Fernandes Pinheiro 2013-05-13 16:11:00 PDT
Created attachment 201644 [details]
Remove RenderTheme::supportsCalendarPicker
Comment 2 Daker Fernandes Pinheiro 2013-05-13 16:13:08 PDT
Created attachment 201645 [details]
Remove RenderTheme::supportsCalendarPicker
Comment 3 Benjamin Poulain 2013-05-13 20:29:44 PDT
Comment on attachment 201645 [details]
Remove RenderTheme::supportsCalendarPicker

Good catch, it looks like this was a chromium feature without flags.
Comment 4 Jesus Sanchez-Palencia 2013-05-14 06:47:59 PDT
Comment on attachment 201645 [details]
Remove RenderTheme::supportsCalendarPicker

great!
Comment 5 WebKit Commit Bot 2013-05-14 07:29:24 PDT
Comment on attachment 201645 [details]
Remove RenderTheme::supportsCalendarPicker

Clearing flags on attachment: 201645

Committed r150069: <http://trac.webkit.org/changeset/150069>
Comment 6 WebKit Commit Bot 2013-05-14 07:29:25 PDT
All reviewed patches have been landed.  Closing bug.
Comment 7 Kent Tamura 2013-05-14 14:02:36 PDT
(In reply to comment #5)
> Committed r150069: <http://trac.webkit.org/changeset/150069>

This removed INPUT_MULTIPLE_FIELDS_UI (inline-editing date/time types) + popup calendar picker configuration like Chromium.  Have you confirmed any WebKit ports has no plan to use this configuration?

If this change is ok for any ports, you can remove ENABLE_CALENDAR_PICKER code (+ Source/WebCore/Resources/pagepopups/calendarPicker.*) entirely now, and you need to update http://trac.webkit.org/wiki/EnableFormFeatures .
Comment 8 Daker Fernandes Pinheiro 2013-05-15 06:01:41 PDT
That's why I opened the bug.
To discuss if someone does need it.