Bug 116019 - CLoop llint backend should not use the d8 register as scratch register
Summary: CLoop llint backend should not use the d8 register as scratch register
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-13 02:43 PDT by Peter Wang
Modified: 2013-05-23 23:56 PDT (History)
7 users (show)

See Also:


Attachments
Patch (1.15 KB, patch)
2013-05-13 02:45 PDT, Peter Wang
no flags Details | Formatted Diff | Diff
Archive of layout-test-results from webkit-ews-11 for mac-mountainlion-wk2 (525.43 KB, application/zip)
2013-05-13 15:54 PDT, Build Bot
no flags Details
Patch (1.18 KB, patch)
2013-05-23 20:58 PDT, Peter Wang
no flags Details | Formatted Diff | Diff
Patch (1.18 KB, patch)
2013-05-23 23:10 PDT, Peter Wang
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Wang 2013-05-13 02:43:19 PDT
Thanks to the patch for bug#114811, a strange crush of our port is fixed.
And actually there is another d8 used as "scratch register" in "cloop.rb", although it's not used so far.

And I've noticed of that "sg5.lee@samsung.com" first mentioned how to resolve it in bug#114495.
I just open this bug to suggest to fix the reminding things.
Comment 1 Peter Wang 2013-05-13 02:45:38 PDT
Created attachment 201539 [details]
Patch
Comment 2 Peter Wang 2013-05-13 02:52:01 PDT
(In reply to comment #1)
> Created an attachment (id=201539) [details]
> Patch

Just upload this patch to propose to fix the remaining part.
Comment 3 Csaba Osztrogonác 2013-05-13 03:28:49 PDT
LGTM, but it would be better if a JSC expert can review it.
Comment 4 Build Bot 2013-05-13 15:54:32 PDT
Comment on attachment 201539 [details]
Patch

Attachment 201539 [details] did not pass mac-wk2-ews (mac-wk2):
Output: http://webkit-queues.appspot.com/results/467317

New failing tests:
editing/style/5065910.html
Comment 5 Build Bot 2013-05-13 15:54:33 PDT
Created attachment 201641 [details]
Archive of layout-test-results from webkit-ews-11 for mac-mountainlion-wk2

The attached test failures were seen while running run-webkit-tests on the mac-wk2-ews.
Bot: webkit-ews-11  Port: mac-mountainlion-wk2  Platform: Mac OS X 10.8.2
Comment 6 Csaba Osztrogonác 2013-05-23 08:50:09 PDT
ping?
Comment 7 Peter Wang 2013-05-23 20:58:22 PDT
Created attachment 202760 [details]
Patch
Comment 8 Peter Wang 2013-05-23 21:03:52 PDT
(In reply to comment #6)
> ping
Sorry to keep waiting.
 It's weird. My local MAC build can pass the case mentioned as failed case in comment#4.
I just re-upload patch to have a try again.
Comment 9 Charles Wei 2013-05-23 21:26:22 PDT
Comment on attachment 202760 [details]
Patch

Try to resubmit the patch since the author believes last regression is not related to this patch.
Comment 10 WebKit Commit Bot 2013-05-23 23:00:01 PDT
Comment on attachment 202760 [details]
Patch

Rejecting attachment 202760 [details] from commit-queue.

Failed to run "['/Volumes/Data/EWS/WebKit/Tools/Scripts/webkit-patch', '--status-host=webkit-queues.appspot.com', '--bot-id=webkit-cq-03', 'validate-changelog', '--check-oops', '--non-interactive', 202760, '--port=mac']" exit_code: 1 cwd: /Volumes/Data/EWS/WebKit

Csaba Osztrogonac found in /Volumes/Data/EWS/WebKit/Source/JavaScriptCore/ChangeLog does not appear to be a valid reviewer according to committers.py.
/Volumes/Data/EWS/WebKit/Source/JavaScriptCore/ChangeLog neither lists a valid reviewer nor contains the string "Unreviewed" or "Rubber stamp" (case insensitive).

Full output: http://webkit-queues.appspot.com/results/682007
Comment 11 Peter Wang 2013-05-23 23:10:28 PDT
Created attachment 202769 [details]
Patch
Comment 12 Charles Wei 2013-05-23 23:14:40 PDT
Comment on attachment 202769 [details]
Patch

resubmit after fixing the typo of the Reviewer.
Comment 13 WebKit Commit Bot 2013-05-23 23:54:59 PDT
The commit-queue encountered the following flaky tests while processing attachment 202769 [details]:

svg/batik/text/textAnchor.svg bug 116285 (authors: darin@apple.com and zimmermann@kde.org)
svg/batik/text/textEffect3.svg bug 116521 (authors: darin@apple.com and zimmermann@kde.org)
media/event-queue-crash.html bug 114177 (author: shinyak@chromium.org)
media/video-zoom.html bug 116704 (authors: fischman@chromium.org, jamesr@chromium.org, rniwa@webkit.org, and vrk@chromium.org)
The commit-queue is continuing to process your patch.
Comment 14 WebKit Commit Bot 2013-05-23 23:56:11 PDT
Comment on attachment 202769 [details]
Patch

Clearing flags on attachment: 202769

Committed r150630: <http://trac.webkit.org/changeset/150630>
Comment 15 WebKit Commit Bot 2013-05-23 23:56:14 PDT
All reviewed patches have been landed.  Closing bug.