Bug 115900 - Remove ScriptInstance.h
Summary: Remove ScriptInstance.h
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Anders Carlsson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-10 05:36 PDT by Anders Carlsson
Modified: 2013-05-10 05:51 PDT (History)
5 users (show)

See Also:


Attachments
Patch (15.13 KB, patch)
2013-05-10 05:40 PDT, Anders Carlsson
kling: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Anders Carlsson 2013-05-10 05:36:22 PDT
Remove ScriptInstance.h
Comment 1 Anders Carlsson 2013-05-10 05:40:15 PDT
Created attachment 201338 [details]
Patch
Comment 2 WebKit Commit Bot 2013-05-10 05:41:18 PDT
Attachment 201338 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/WebCore/ChangeLog', u'Source/WebCore/GNUmakefile.list.am', u'Source/WebCore/WebCore.vcproj/WebCore.vcproj', u'Source/WebCore/WebCore.vcxproj/WebCore.vcxproj', u'Source/WebCore/WebCore.vcxproj/WebCore.vcxproj.filters', u'Source/WebCore/WebCore.xcodeproj/project.pbxproj', u'Source/WebCore/bindings/js/ScriptController.h', u'Source/WebCore/bindings/js/ScriptControllerMac.mm', u'Source/WebCore/bindings/js/ScriptInstance.h', u'Source/WebCore/html/HTMLPlugInElement.cpp', u'Source/WebCore/html/HTMLPlugInElement.h', u'Source/WebCore/platform/graphics/wince/MediaPlayerProxy.h', u'Source/WebCore/rendering/RenderEmbeddedObject.cpp', u'Source/WebCore/rendering/RenderSnapshottedPlugIn.cpp']" exit_code: 1
Source/WebCore/platform/graphics/wince/MediaPlayerProxy.h:56:  The return type should use PassRefPtr instead of RefPtr.  [readability/pass_ptr] [5]
Total errors found: 1 in 8 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Andreas Kling 2013-05-10 05:44:03 PDT
Comment on attachment 201338 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=201338&action=review

r=me

>> Source/WebCore/platform/graphics/wince/MediaPlayerProxy.h:56
>> -        ScriptInstance pluginInstance();
>> +        RefPtr<JSC::Bindings::Instance> pluginInstance();
> 
> The return type should use PassRefPtr instead of RefPtr.  [readability/pass_ptr] [5]

wat
Comment 4 Anders Carlsson 2013-05-10 05:51:30 PDT
Committed r149871: <http://trac.webkit.org/changeset/149871>