Bug 115652 - Use OwnPtr instead of deleteAllValues in KeyframeValueList
Summary: Use OwnPtr instead of deleteAllValues in KeyframeValueList
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Platform (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Darin Adler
URL:
Keywords:
: 115678 (view as bug list)
Depends on:
Blocks: 73757
  Show dependency treegraph
 
Reported: 2013-05-06 09:29 PDT by Darin Adler
Modified: 2013-05-07 09:13 PDT (History)
10 users (show)

See Also:


Attachments
Patch (16.29 KB, patch)
2013-05-06 09:38 PDT, Darin Adler
no flags Details | Formatted Diff | Diff
Patch (18.77 KB, patch)
2013-05-06 10:06 PDT, Darin Adler
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Darin Adler 2013-05-06 09:29:36 PDT
Use OwnPtr instead of deleteAllValues in KeyframeValueList
Comment 1 Darin Adler 2013-05-06 09:38:19 PDT
Created attachment 200709 [details]
Patch
Comment 2 Early Warning System Bot 2013-05-06 09:51:49 PDT
Comment on attachment 200709 [details]
Patch

Attachment 200709 [details] did not pass qt-wk2-ews (qt-wk2):
Output: http://webkit-queues.appspot.com/results/377204
Comment 3 Darin Adler 2013-05-06 10:06:56 PDT
Created attachment 200718 [details]
Patch
Comment 4 Noam Rosenthal 2013-05-06 10:20:53 PDT
Thanks, I've always wanted to do this! Will let smfr do the reviewing :)
Comment 5 Anders Carlsson 2013-05-06 15:00:20 PDT
I just did https://bugs.webkit.org/show_bug.cgi?id=115678 !
Comment 6 WebKit Commit Bot 2013-05-06 21:30:47 PDT
Comment on attachment 200718 [details]
Patch

Clearing flags on attachment: 200718

Committed r149661: <http://trac.webkit.org/changeset/149661>
Comment 7 WebKit Commit Bot 2013-05-06 21:30:50 PDT
All reviewed patches have been landed.  Closing bug.
Comment 8 Darin Adler 2013-05-07 09:13:04 PDT
*** Bug 115678 has been marked as a duplicate of this bug. ***