Bug 115475 - REGRESSION(r147548): Broken comboboxes
Summary: REGRESSION(r147548): Broken comboboxes
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Linux
: P2 Critical
Assignee: Nobody
URL:
Keywords: Gtk
Depends on:
Blocks:
 
Reported: 2013-05-01 07:52 PDT by Sergio Villar Senin
Modified: 2013-05-14 23:42 PDT (History)
5 users (show)

See Also:


Attachments
Patch (1.62 KB, patch)
2013-05-14 04:01 PDT, Carlos Garcia Campos
gns: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Sergio Villar Senin 2013-05-01 07:52:40 PDT
Comboboxes are not working at all in WebKitGtk+, neither for WK1 not WK2. The popup window is not displayed, and the combobox does not even work with the keyboard.
Comment 1 Carlos Garcia Campos 2013-05-14 03:55:53 PDT
I don't think this is specific to GTK. The problem is that r147548 made the popup to be closed when a blur event is received. Right before showing the popup the input element is focused, so that after the the popup is shown the focus event is emitted and the event handler is called again hiding the popup. I guess this doesn't happen in other platforms because they run a nested mainloop for popups. A possible solution would be to check that the current element has actually lost the focus before hiding the popup.
Comment 2 Carlos Garcia Campos 2013-05-14 04:01:00 PDT
Created attachment 201695 [details]
Patch
Comment 3 Carlos Garcia Campos 2013-05-14 23:42:06 PDT
Committed r150102: <http://trac.webkit.org/changeset/150102>