Bug 115240 - [GTK] Compilation of ProcessLauncherGtk.cpp fails due to unresolved symbols
Summary: [GTK] Compilation of ProcessLauncherGtk.cpp fails due to unresolved symbols
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit2 (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
: 115306 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-04-26 03:37 PDT by Eduardo Lima Mitev
Modified: 2013-04-27 09:46 PDT (History)
4 users (show)

See Also:


Attachments
Includes "sys/socket.h" in ProcessLauncherGtk.cpp, if OS is Linux (1.61 KB, patch)
2013-04-26 03:52 PDT, Eduardo Lima Mitev
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Eduardo Lima Mitev 2013-04-26 03:37:14 PDT
Building WebKit Gtk port using build-webkit script fails in my system (up-to-date Debian Wheezy 64bits) with:

../../Source/WebKit2/UIProcess/Launcher/gtk/ProcessLauncherGtk.cpp: In member function 'void WebKit::ProcessLauncher::launchProcess()':
../../Source/WebKit2/UIProcess/Launcher/gtk/ProcessLauncherGtk.cpp:77:20: error: 'AF_UNIX' was not declared in this scope
../../Source/WebKit2/UIProcess/Launcher/gtk/ProcessLauncherGtk.cpp:77:29: error: 'SOCK_STREAM' was not declared in this scope
../../Source/WebKit2/UIProcess/Launcher/gtk/ProcessLauncherGtk.cpp:77:52: error: 'socketpair' was not declared in this scope
make[1]: *** [Source/WebKit2/UIProcess/Launcher/gtk/libwebkit2gtk_3_0_la-ProcessLauncherGtk.lo] Error 1
make[1]: *** Waiting for unfinished jobs....
make[1]: Leaving directory `/opt/jhbuild/gnome3/checkout/WebKit/WebKitBuild/Release'
make: *** [all] Error 2

The error goes away by including "sys/socket.h".
Comment 1 Eduardo Lima Mitev 2013-04-26 03:52:11 PDT
Created attachment 199810 [details]
Includes "sys/socket.h" in ProcessLauncherGtk.cpp, if OS is Linux
Comment 2 Eduardo Lima Mitev 2013-04-26 03:57:58 PDT
Adding xlopez and mrobinson to CC.
Comment 3 WebKit Commit Bot 2013-04-26 09:15:03 PDT
Comment on attachment 199810 [details]
Includes "sys/socket.h" in ProcessLauncherGtk.cpp, if OS is Linux

Clearing flags on attachment: 199810

Committed r149192: <http://trac.webkit.org/changeset/149192>
Comment 4 WebKit Commit Bot 2013-04-26 09:15:04 PDT
All reviewed patches have been landed.  Closing bug.
Comment 5 Zan Dobersek 2013-04-27 09:46:20 PDT
*** Bug 115306 has been marked as a duplicate of this bug. ***