Bug 114953 - BlackBerry: fix call to PluginLayerWebKitThread::setHolePunchRect()
Summary: BlackBerry: fix call to PluginLayerWebKitThread::setHolePunchRect()
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit BlackBerry (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks: 111729
  Show dependency treegraph
 
Reported: 2013-04-22 06:36 PDT by Alberto Garcia
Modified: 2013-05-09 11:37 PDT (History)
2 users (show)

See Also:


Attachments
Patch (1.38 KB, patch)
2013-04-22 06:44 PDT, Alberto Garcia
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alberto Garcia 2013-04-22 06:36:08 PDT
We have this error:

Source/WebCore/plugins/blackberry/NPCallbacksBlackBerry.cpp:68:28: error: 'class WebCore::LayerWebKitThread' has no member named 'setHolePunchRect'

The problem is that HolePunchData holds a pointer to LayerWebKitThread (PlatformLayer).
Comment 1 Alberto Garcia 2013-04-22 06:44:17 PDT
Created attachment 199023 [details]
Patch

This would be the simplest patch, and is consistent with what it's
already being done in other parts of the same code.

However I wonder if it wouldn't be better to change the pointer in
HolePunchData directly.
Comment 2 Rob Buis 2013-05-09 11:07:58 PDT
Comment on attachment 199023 [details]
Patch

LGTM.
Comment 3 WebKit Commit Bot 2013-05-09 11:37:53 PDT
Comment on attachment 199023 [details]
Patch

Clearing flags on attachment: 199023

Committed r149827: <http://trac.webkit.org/changeset/149827>
Comment 4 WebKit Commit Bot 2013-05-09 11:37:55 PDT
All reviewed patches have been landed.  Closing bug.