Bug 11478 - WebKit Probably should size to fit images at image urls.
Summary: WebKit Probably should size to fit images at image urls.
Status: RESOLVED DUPLICATE of bug 5400
Alias: None
Product: WebKit
Classification: Unclassified
Component: Images (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P2 Enhancement
Assignee: Nobody
URL: http://xn--sailor-183m.com/imgs/IMG_0...
Keywords:
Depends on:
Blocks:
 
Reported: 2006-10-31 20:40 PST by Rosyna
Modified: 2006-11-01 01:15 PST (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rosyna 2006-10-31 20:40:15 PST
Just about every other image viewer in existence sizes to fit images that are too large to be displayed in the current window. I think WebKit should do so as well. For example, http://xn--sailor-183m.com/imgs/IMG_0188.tif is my favorite photo ever so far but viewing it in WebKit ToT results in it being displayed at 72dpi, which is FAR too large to display in a window. If it would just size to fit, all would be well with the world.

I'm not talking about images displayed on a webpage either. So http://sailor月.com/japan/Japan-Pages/Image439.html appearing out of the view is ok.
Comment 1 Dave Hyatt 2006-10-31 22:32:57 PST
Yeah, I enthusiastically agree.  The way Firefox does it is fantastic.

Comment 2 mitz 2006-11-01 01:15:58 PST

*** This bug has been marked as a duplicate of 5400 ***