Bug 114706 - Need a new layout milestone to notify bundle clients when the header has been flushed
Summary: Need a new layout milestone to notify bundle clients when the header has been...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Beth Dakin
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2013-04-16 15:24 PDT by Beth Dakin
Modified: 2013-04-16 16:00 PDT (History)
5 users (show)

See Also:


Attachments
Patch (15.64 KB, patch)
2013-04-16 15:32 PDT, Beth Dakin
simon.fraser: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Beth Dakin 2013-04-16 15:24:36 PDT
There is API to give a WKView a header, and we need a new layout milestone to notify bundle clients when that header has been flushed.

<rdar://problem/13657284>
Comment 1 Beth Dakin 2013-04-16 15:32:46 PDT
Created attachment 198444 [details]
Patch
Comment 2 Simon Fraser (smfr) 2013-04-16 15:45:16 PDT
Comment on attachment 198444 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=198444&action=review

> Source/WebCore/rendering/RenderLayerCompositor.cpp:382
> +            if (page->layoutMilestones() & DidFirstFlushForHeaderLayer) {

Maybe we can rename Page::layoutMilestones() to Page::requestedLayoutMilestones() in a future patch to make its role clearer.

> Source/WebKit2/Shared/API/c/WKPageLoadTypes.h:55
> +    // Note that this enum has a fourth, private member that is defined in WKPageLoadTypesPrivate.h

I think it would be better to add 
kWKReserved1 = 1 << 3 or something, so that future changes are less likely to break things.
Comment 3 Beth Dakin 2013-04-16 16:00:20 PDT
(In reply to comment #2)
> (From update of attachment 198444 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=198444&action=review
> 
> > Source/WebCore/rendering/RenderLayerCompositor.cpp:382
> > +            if (page->layoutMilestones() & DidFirstFlushForHeaderLayer) {
> 
> Maybe we can rename Page::layoutMilestones() to Page::requestedLayoutMilestones() in a future patch to make its role clearer.
> 

Good idea. Will do.

> > Source/WebKit2/Shared/API/c/WKPageLoadTypes.h:55
> > +    // Note that this enum has a fourth, private member that is defined in WKPageLoadTypesPrivate.h
> 
> I think it would be better to add 
> kWKReserved1 = 1 << 3 or something, so that future changes are less likely to break things.

Changed this!

http://trac.webkit.org/changeset/148564