Bug 11452 - REGRESSION (r16736-r16801): Incorrect repaint of fixed boxes
Summary: REGRESSION (r16736-r16801): Incorrect repaint of fixed boxes
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P1 Normal
Assignee: Nobody
URL:
Keywords: Regression
: 11969 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-10-29 16:12 PST by mitz
Modified: 2006-12-27 15:58 PST (History)
3 users (show)

See Also:


Attachments
Test case (341 bytes, text/html)
2006-10-29 16:14 PST, mitz
no flags Details
Add back RenderView::computeAbsoluteRepaintRect() (33.99 KB, patch)
2006-12-26 23:18 PST, mitz
hyatt: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description mitz 2006-10-29 16:12:47 PST
Fixed boxes aren't treated as such for repaint rect calculation, so if the document is scrolled, they don't repaint properly. See attached test case.

I'll try to narrow down the revision range later, but this regression is probably from the change that rendered "fixed" parameter to computeAbsoluteRepaintRect() useless.
Comment 1 mitz 2006-10-29 16:14:01 PST
Created attachment 11278 [details]
Test case

Pre-scrolled for your convenience, just click Test.
Comment 2 mitz 2006-12-25 12:10:07 PST
*** Bug 11969 has been marked as a duplicate of this bug. ***
Comment 3 mitz 2006-12-25 12:17:48 PST
(In reply to comment #0)
> the change that rendered "fixed" parameter to
> computeAbsoluteRepaintRect() useless.

http://trac.webkit.org/projects/webkit/changeset/16764
Comment 4 mitz 2006-12-26 23:18:24 PST
Created attachment 12052 [details]
Add back RenderView::computeAbsoluteRepaintRect()
Comment 5 Dave Hyatt 2006-12-27 00:21:49 PST
Comment on attachment 12052 [details]
Add back RenderView::computeAbsoluteRepaintRect()

r=me
Comment 6 Sam Weinig 2006-12-27 15:58:54 PST
Landed in r18443.