Bug 114376 - z-index of 0 on an iframe results in elements on top in fullscreen
Summary: z-index of 0 on an iframe results in elements on top in fullscreen
Status: RESOLVED DUPLICATE of bug 111637
Alias: None
Product: WebKit
Classification: Unclassified
Component: Frames (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Nobody
URL: http://www.behance.net/gallery/Andrey...
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-10 12:40 PDT by Brad Dougherty
Modified: 2013-04-11 07:48 PDT (History)
1 user (show)

See Also:


Attachments
Screenshot of the iframe element in full screen (2.90 MB, image/png)
2013-04-10 12:41 PDT, Brad Dougherty
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Brad Dougherty 2013-04-10 12:40:17 PDT
If an iframe has a z-index of 0, certain elements from the outer page will show up on top of the iframe contents if an element inside the iframe is put into fullscreen.

Behavior can be seen on: http://www.behance.net/gallery/Andrey-Pratama-Showreel-2012/8010347

If the z-index of the iframe is changed to 1, it works as expected.
Comment 1 Brad Dougherty 2013-04-10 12:41:04 PDT
Created attachment 197389 [details]
Screenshot of the iframe element in full screen
Comment 2 Jer Noble 2013-04-10 22:19:34 PDT
Brad, can you try a WebKit nightly? We recently fixed a full screen bug involving <iframe>s and stacking layers.
Comment 3 Jer Noble 2013-04-10 22:22:00 PDT
Specifically, this was reported in bug #111637 and fixed in <http://trac.webkit.org/changeset/145001>,
Comment 4 Brad Dougherty 2013-04-11 07:48:03 PDT
Indeed it is fixed. Sorry about the duplicate.

*** This bug has been marked as a duplicate of bug 111637 ***