Bug 11435 - REGRESSION (r17098): Crash when clicking in an XSLT document while it's loading
Summary: REGRESSION (r17098): Crash when clicking in an XSLT document while it's loading
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P1 Normal
Assignee: Dave Hyatt
URL: http://build.webkit.org/results/page-...
Keywords: InRadar, Regression
Depends on:
Blocks:
 
Reported: 2006-10-27 10:16 PDT by mitz
Modified: 2007-02-27 12:34 PST (History)
1 user (show)

See Also:


Attachments
Make sure RenderView always paints box decorations (542 bytes, patch)
2007-02-27 12:17 PST, Dave Hyatt
mitz: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description mitz 2006-10-27 10:16:19 PDT
Go to the URL and while it's loading, resize the window and click inside it. WebKit crashes:


0   com.apple.WebCore        	0x0112202c WebCore::FrameView::handleMousePressEvent(WebCore::PlatformMouseEvent const&) + 348
1   com.apple.WebCore        	0x01111f84 WebCore::FrameMac::mouseDown(NSEvent*) + 612
2   com.apple.WebKit         	0x00336350 -[WebHTMLView mouseDown:] + 272
3   com.apple.AppKit         	0x93767890 -[NSWindow sendEvent:] + 4616
...

Even before the crash, during resize you get garbage in the window (in debug builds, you see the red fill).

Rolling out r17098 (Prepare for the elimination of the RenderLayer for <html> elements) fixes the bug.
Comment 1 Stephanie Lewis 2006-11-08 15:21:29 PST
This looks like a duplicate of bug 11111

*** This bug has been marked as a duplicate of 11111 ***
Comment 2 Stephanie Lewis 2006-11-08 15:34:08 PST
radar 4173996
Comment 3 mitz 2006-12-22 10:48:46 PST
Another related issue is that 0-length text documents don't have a root layer ( try data:text/plain, ).
Comment 4 Maciej Stachowiak 2007-02-07 05:28:45 PST
On 12/18/06, Geoff said in the Radar that he could not reproduce. Not sure if the cited Radar number is right though.
Comment 5 Dave Hyatt 2007-02-27 12:17:47 PST
Created attachment 13407 [details]
Make sure RenderView always paints box decorations
Comment 6 mitz 2007-02-27 12:19:50 PST
Comment on attachment 13407 [details]
Make sure RenderView always paints box decorations

r=me
Comment 7 Dave Hyatt 2007-02-27 12:34:50 PST
Fixed.