Bug 113920 - Mouseover event fired on cursor style change
Summary: Mouseover event fired on cursor style change
Status: RESOLVED DUPLICATE of bug 101857
Alias: None
Product: WebKit
Classification: Unclassified
Component: DOM (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Nobody
URL: http://jsfiddle.net/d74EP/5/
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-03 21:32 PDT by Marc Baumbach
Modified: 2019-02-06 09:18 PST (History)
1 user (show)

See Also:


Attachments
Test case (524 bytes, text/html)
2013-04-03 21:42 PDT, Marc Baumbach
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marc Baumbach 2013-04-03 21:32:54 PDT
Whenever changing the cursor, WebKit fires a mousemove event. This doesn't seem correct, or at least is inconsistent with other browsers as Firefox and Internet Explorer don't seem to exhibit this problem. If there's some documentation in the specification that states that this can happen, a pointer to that would be useful.

Steps to reproduce:

1. Load the JSFiddle at the URL above.
2. Click (to focus) on the Result area in the bottom right quadrant.
3. Type 'a' to cause a cursor change to "auto" and 's' to cause a cursor change to "move."

Result: Any time the cursor changes to a different style, a mousemove event is fired. Repeated calls to set the cursor style to the current style does not cause mousemove events.
Comment 1 Marc Baumbach 2013-04-03 21:42:12 PDT
Created attachment 196434 [details]
Test case

Attached a test case in case the jsfiddle is inaccessible.
Comment 2 Alexey Proskuryakov 2013-04-04 09:39:23 PDT

*** This bug has been marked as a duplicate of bug 101857 ***
Comment 3 Lucas Forschler 2019-02-06 09:18:54 PST
Mass move bugs into the DOM component.