Bug 113839 - Display: switching from display:block to display: table-cell getting confused on window resize when using media queries
Summary: Display: switching from display:block to display: table-cell getting confused...
Status: RESOLVED DUPLICATE of bug 138167
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL: http://jsbin.com/iliniw/1/edit
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-02 17:33 PDT by Mohsen
Modified: 2022-06-09 11:38 PDT (History)
6 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mohsen 2013-04-02 17:33:58 PDT
Chrome Version       : 27.0.1454.0 (Official Build 190834) canary
URLs (if applicable) : http://jsbin.com/iliniw/1/edit
Other browsers tested:
Add OK or FAIL after other browsers where you have tested this issue:
     Safari 5: FAIL
  Firefox 4.x: OK
       IE 7/8/9:  only tested in IE8: FAIL
       Safari 6: FAIL

What steps will reproduce the problem?
1. Go to this URL: http://jsbin.com/iliniw/1/edit
2. Resize the preview window to make it narrow (less than 500px)
3. Resize the preview window to make it wide (more than 500px)

What is the expected result?
columns should show up next to each other with similar width 

What happens instead?
first column is wider and other two columns are smaller

Please provide any additional information below. Attach a screenshot if
possible.

Seems like it's a webkit bug.

I've filed a similar bug in bug in Chromium project.  https://code.google.com/p/chromium/issues/detail?id=225946
Comment 1 Chris Rebert 2016-02-18 23:50:10 PST
Presumably a duplicate of bug 138167.
Comment 2 Ahmad Saleem 2022-06-09 09:36:16 PDT
I am unable to reproduce following bug using URL (JS Bin) in Safari 15.5 on macOS 12.4. Across all other browsers, Chrome Canary 104 and Firefox Nightly 103, it works same.

Columns show up when resizing with enough width and disappear when making view window smaller. All spaced tables look same across browsers.

If I am testing incorrectly, please retest accordingly. Although I think this was fixed within Webkit along the lines and now can be marked as "RESOLVED CONFIGURATION CHANGED". Thanks!
Comment 3 Alexey Proskuryakov 2022-06-09 11:38:20 PDT
Duping as suggested.

*** This bug has been marked as a duplicate of bug 138167 ***