Bug 113836 - REGRESSION (r145869): Right-click on SWF contents displays the context menu at the wrong place
Summary: REGRESSION (r145869): Right-click on SWF contents displays the context menu a...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Plug-ins (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel All
: P1 Normal
Assignee: Andreas Kling
URL: http://helpx.adobe.com/flash-player/k...
Keywords: InRadar, Regression
Depends on:
Blocks:
 
Reported: 2013-04-02 16:50 PDT by alejandro.quiroz
Modified: 2013-04-12 08:12 PDT (History)
3 users (show)

See Also:


Attachments
Patch (8.30 KB, patch)
2013-04-12 07:27 PDT, Andreas Kling
no flags Details | Formatted Diff | Diff
Patch (10.45 KB, patch)
2013-04-12 08:08 PDT, Andreas Kling
andersca: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description alejandro.quiroz 2013-04-02 16:50:55 PDT
Right-clicking on Flash contents in the Safari nightly build displays the context menu at the wrong location.

I was able to reproduce it on:

+ Safari/WebKit nightly r147249 and subsequent updates.  I got the sandboxed Safari/Webkit from http://nightly.webkit.org.
+ Mac OS 10.7.5
+ Flash Player 11.6.602.180
+ Any page with SWF content.  I used http://helpx.adobe.com/flash-player/kb/find-version-flash-player.html

The problem seems to be with the PopUpContextMenu NPAPI when computing the menu origin coordinates.  This problem is accentuated if I move Safari window and the SWF contents near the bottom of the screen and I right-click to display the context menu.  It appears on the top of the screen.

The problem doesn't exist on Safari 6.0.3 (7536.28.10).
Comment 1 Alexey Proskuryakov 2013-04-05 10:59:55 PDT
<rdar://problem/13587624>
Comment 2 Andreas Kling 2013-04-05 11:06:37 PDT
Regression URL for clicky convenience: <http://trac.webkit.org/changeset/145869>
Comment 3 Andreas Kling 2013-04-12 07:27:49 PDT
Created attachment 197848 [details]
Patch
Comment 4 Andreas Kling 2013-04-12 08:08:53 PDT
Created attachment 197849 [details]
Patch

Incorporating some IRC comments from andersca.
Comment 5 Andreas Kling 2013-04-12 08:12:32 PDT
Committed r148278: <http://trac.webkit.org/changeset/148278>