RESOLVED FIXED Bug 113264
Rename HTMLInputElement::isIndeterminate to Element::shouldAppearIndeterminate
https://bugs.webkit.org/show_bug.cgi?id=113264
Summary Rename HTMLInputElement::isIndeterminate to Element::shouldAppearIndeterminate
Kent Tamura
Reported 2013-03-25 19:15:04 PDT
HTMLInputElement has indeterminate() and isIndeterminate(). It's super confusing.
Attachments
Patch (9.61 KB, patch)
2013-03-25 19:25 PDT, Kent Tamura
no flags
Kent Tamura
Comment 1 2013-03-25 19:25:35 PDT
Kentaro Hara
Comment 2 2013-03-25 22:32:18 PDT
Comment on attachment 194981 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=194981&action=review > Source/WebCore/html/HTMLProgressElement.cpp:173 > + return !isDeterminate(); As far as I see the removed code in SelectorChecker.cpp, it looks like that isDeterminate() is a negation of isIndeterminate(). In this patch, isIndeterminate() is remaned to shouldAppearIndeterminate(). Then, don't you want to rename isDeterminate() to something consistent as well (e.g. shouldAppearDeterminate()) ?
Kent Tamura
Comment 3 2013-03-25 22:54:59 PDT
Comment on attachment 194981 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=194981&action=review >> Source/WebCore/html/HTMLProgressElement.cpp:173 >> + return !isDeterminate(); > > As far as I see the removed code in SelectorChecker.cpp, it looks like that isDeterminate() is a negation of isIndeterminate(). In this patch, isIndeterminate() is remaned to shouldAppearIndeterminate(). Then, don't you want to rename isDeterminate() to something consistent as well (e.g. shouldAppearDeterminate()) ? I understand you think it's inconsistent, however I feel it's not inconsistent because their roles are different. shouldAppearDeterminate is a hook for CSS selector matching, isDeterminate represents "determinate" concept in the standard and it is just for HTMLProgressElement.
Kentaro Hara
Comment 4 2013-03-25 23:24:11 PDT
Comment on attachment 194981 [details] Patch Makes sense. Thanks for the clarification.
WebKit Review Bot
Comment 5 2013-03-26 01:28:34 PDT
Comment on attachment 194981 [details] Patch Clearing flags on attachment: 194981 Committed r146860: <http://trac.webkit.org/changeset/146860>
WebKit Review Bot
Comment 6 2013-03-26 01:28:38 PDT
All reviewed patches have been landed. Closing bug.
Note You need to log in before you can comment on or make changes to this bug.