Bug 113227 - [Mac] Several transitions tests fail due to "fail to pause" errors
Summary: [Mac] Several transitions tests fail due to "fail to pause" errors
Status: RESOLVED DUPLICATE of bug 137883
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-25 11:12 PDT by Ryosuke Niwa
Modified: 2014-11-13 17:08 PST (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ryosuke Niwa 2013-03-25 11:12:57 PDT
http://build.webkit.org/results/Apple%20MountainLion%20Release%20WK1%20(Tests)/r146779%20(8304)/results.html

e.g.
--- /Volumes/Data/slave/mountainlion-release-tests-wk1/build/layout-test-results/transitions/cross-fade-background-image-expected.txt
+++ /Volumes/Data/slave/mountainlion-release-tests-wk1/build/layout-test-results/transitions/cross-fade-background-image-actual.txt
@@ -1,3 +1,5 @@
+CONSOLE MESSAGE: line 240: Failed to pause 'background-image' transition on element 'box'
+CONSOLE MESSAGE: line 240: Failed to pause 'background-image' transition on element 'boxShorthand'
 layer at (0,0) size 800x600
   RenderView at (0,0) size 800x600
 layer at (0,0) size 800x600
@@ -5,10 +7,14 @@
     RenderBody {BODY} at (8,10) size 784x582
       RenderBlock {DIV} at (10,0) size 200x200
       RenderBlock {DIV} at (10,210) size 200x200
-      RenderBlock {DIV} at (0,420) size 784x36
-        RenderText {#text} at (0,0) size 581x18
-          text run at (0,0) width 581: "PASS - \"background-image\" property for \"box\" element at 0.5s saw something close to: 0.5"
-        RenderBR {BR} at (581,14) size 0x0
-        RenderText {#text} at (0,18) size 646x18
-          text run at (0,18) width 646: "PASS - \"background-image\" property for \"boxShorthand\" element at 0.5s saw something close to: 0.5"
-        RenderBR {BR} at (646,32) size 0x0
+      RenderBlock {DIV} at (0,420) size 784x108
+        RenderText {#text} at (0,0) size 545x54
+          text run at (0,0) width 545: "FAIL - \"background-image\" property for \"box\" element at 0.5s expected: 0.5 but saw:"
+          text run at (0,18) width 357: "url(file:///Volumes/Data/slave/mountainlion-release-tests-"
+          text run at (0,36) width 446: "wk1/build/LayoutTests/fast/backgrounds/repeat/resources/nav.blue.gif)"
+        RenderBR {BR} at (446,50) size 0x0
+        RenderText {#text} at (0,54) size 610x54
+          text run at (0,54) width 610: "FAIL - \"background-image\" property for \"boxShorthand\" element at 0.5s expected: 0.5 but saw:"
+          text run at (0,72) width 357: "url(file:///Volumes/Data/slave/mountainlion-release-tests-"
+          text run at (0,90) width 446: "wk1/build/LayoutTests/fast/backgrounds/repeat/resources/nav.blue.gif)"
+        RenderBR {BR} at (446,104) size 0x0
Comment 1 Ryosuke Niwa 2013-03-26 12:05:28 PDT
This failure is flaky. It appears that AnimationController::pauseTransitionAtTime is returning false in some cases but I don't know enough about animations to debug this issue at the moment.
Comment 2 Alexey Proskuryakov 2014-11-13 17:08:11 PST
Reverse duping to a bug that saw slightly more action.

*** This bug has been marked as a duplicate of bug 137883 ***