Bug 11297 - GMail Editor: With a rich text message, clicking on newly created a link in editable content visits them
Summary: GMail Editor: With a rich text message, clicking on newly created a link in e...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: HTML Editing (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL:
Keywords: GoogleBug, InRadar
Depends on:
Blocks: 9638 9915
  Show dependency treegraph
 
Reported: 2006-10-14 20:13 PDT by Chris Petersen
Modified: 2007-01-13 02:15 PST (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Petersen 2006-10-14 20:13:18 PDT
*SUMMARY
With a rich text message, clicking on newly created a link in editable content visits them.
This becomes a problem after creating a link in a new rich text. If I click on this link while in a new message, it loads the URL in message body. I can't undo this action.

* STEPS TO REPRODUCE
1. With r17027, login to your Gmail account.
2. Create a new Rich text message
3. Type some text in the message body then select it
4. Click on the link toolbar icon . Type a URL address and click OK.
5. Click on the link that was just created. Instead of placing the caret in this link it's processes. Unfortunately, this URL loads in the message body (replacing your message content). 

* RESULTS
While in a new rich text message that contains a link, clicking this link should not replace the current content in the message body. It should either ignore this click or open this link in a new window.
Comment 1 Chris Petersen 2006-10-14 20:16:41 PDT
This is filed as <rdar://problem/4784457>.
Comment 2 David Harrison 2006-10-30 08:25:16 PST
Which was duped to <rdar://problem/4766635>
Comment 3 David Kilzer (:ddkilzer) 2006-12-26 16:14:27 PST
Radar <rdar://problem/4766635> Safari should never follow links in editable areas (add a WebKitEditableLinkNeverLive option) was fixed in r17776, but this bug still exists in a locally-built debug build of WebKit r18423 with Safari 2.0.4 (419.3) on Mac OS X 10.4.8 (8N1037).

Comment 4 Timothy Hatcher 2006-12-27 14:21:52 PST
This will still be an issue for nightly users since the code change was in Safari. This bug should be close since 4766635 was fixed and is no longer an issue.
Comment 5 David Kilzer (:ddkilzer) 2006-12-27 14:43:12 PST
(In reply to comment #4)
> This will still be an issue for nightly users since the code change was in
> Safari. This bug should be close since 4766635 was fixed and is no longer an
> issue.

Added note to the wiki about this:

http://trac.macosforge.org/projects/webkit/wiki/Known%20incompatibilities%20between%20open-source%20WebKit%20and%20Safari