Bug 112567 - [Qt][Windows] Crash in rendering on gifak.net
Summary: [Qt][Windows] Crash in rendering on gifak.net
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
Depends on:
Reported: 2013-03-18 07:10 PDT by David Rosca
Modified: 2013-11-27 06:05 PST (History)
4 users (show)

See Also:

WinDbg backtrace (27.09 KB, text/plain)
2013-03-18 07:10 PDT, David Rosca
no flags Details
Stack trace with method names & parameters (12.99 KB, text/plain)
2013-03-18 11:08 PDT, Michael Brüning
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Rosca 2013-03-18 07:10:30 PDT
Created attachment 193552 [details]
WinDbg backtrace

Both QtWebKit 2.3 and QtWebKit from Qt 5.0.1 crashes on http://gifak.net most of the time right after finishing loading.
You may need to refresh the site few times to reproduce the crash.

I've tried building QtWebKit with --no-force-sse2 and also Qt with -no-sse2, however it didn't help.

I've attached backtrace from Qt 5.0.1.
For the record, the backtrace is not from QtTestBrowser, but QtTestBrowser is also affected.
Comment 1 Michael Brüning 2013-03-18 09:01:26 PDT
David, could you please add which compiler was used for this?
Comment 2 David Rosca 2013-03-18 09:36:29 PDT
I first used pre-built Qt 5 from qt-project.org, it is using msvc2010.
Then i tried with Qt 4.8 and QtWebKit 2.3 both built with msvc2010, and also with msvc2008. 
The issue is there across the compiler's versions.
Comment 3 Michael Brüning 2013-03-18 11:08:40 PDT
Created attachment 193611 [details]
Stack trace with method names & parameters
Comment 4 Jocelyn Turcotte 2013-03-20 09:45:49 PDT
At the top of the stack: dst = 0x00000000`000000da

So this might be a failing malloc, seeing the actual page I can see how that could happen :)

I tried on Linux with trunk and it doesn't crash, so maybe we have a Windows specific leak somewhere.
Comment 5 David Rosca 2013-03-20 10:56:02 PDT
Tried it now and the process was using 100MB when it crashed (according to task manager).
Comment 6 Ian Monroe 2013-06-20 14:29:19 PDT
http://gifs.gifbin.com/052011/1304618376_tumbleweed-gif.gif always crashes with Qt 4, Qt 5.0.2, Qt 5.1-rc1 under Windows MSVC2010. It works fine in Linux.
Comment 7 Allan Sandfeld Jensen 2013-06-26 03:11:52 PDT
Please check if this crash is fixed by the patch for bug 116041
Comment 8 Allan Sandfeld Jensen 2013-07-03 07:28:34 PDT
(In reply to comment #7)
> Please check if this crash is fixed by the patch for bug 116041

It appears this crash is fixed in WebKit trunk, but not by the patch above.
Comment 9 Michael Brüning 2013-11-27 06:05:57 PST
This has been fixed in the qtwebkit repository in 5.2. Since the Qt port was removed from webkit.org / trunk, please report QtWebKit related bugs here: https://bugreports.qt-project.org/browse/QTBUG/component/19923 .