Bug 112537 - [GTK] Bump the required Clang version to 3.2
Summary: [GTK] Bump the required Clang version to 3.2
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Zan Dobersek
URL:
Keywords: Gtk
Depends on:
Blocks: 109314
  Show dependency treegraph
 
Reported: 2013-03-18 01:06 PDT by Zan Dobersek
Modified: 2013-09-06 23:12 PDT (History)
2 users (show)

See Also:


Attachments
Patch (2.30 KB, patch)
2013-09-06 13:08 PDT, Zan Dobersek
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Zan Dobersek 2013-03-18 01:06:07 PDT
There are currently build errors occurring when using 3.0.

I'd also like to see the GTK port switching to Clang completely, possibly starting with Clang 3.2.
Comment 1 Zan Dobersek 2013-09-06 13:06:10 PDT
Still valid, 3.2 is a necessity, on the 2.2 branch as well.
Comment 2 Zan Dobersek 2013-09-06 13:08:50 PDT
Created attachment 210784 [details]
Patch
Comment 3 Zan Dobersek 2013-09-06 23:12:22 PDT
Comment on attachment 210784 [details]
Patch

Clearing flags on attachment: 210784

Committed r155245: <http://trac.webkit.org/changeset/155245>
Comment 4 Zan Dobersek 2013-09-06 23:12:28 PDT
All reviewed patches have been landed.  Closing bug.