Bug 11245 - HTML5 client-side session & persistent storage should be supported
: HTML5 client-side session & persistent storage should be supported
Status: RESOLVED FIXED
Product: WebKit
Classification: Unclassified
Component: HTML DOM
: 420+
: Macintosh Mac OS X 10.4
: P2 Enhancement
Assigned To: David Carson
http://www.whatwg.org/specs/web-apps/...
: InRadar, ReviewedForRadar
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-10 11:55 PDT by David Carson
Modified: 2008-09-07 12:15 PDT (History)
9 users (show)

See Also:


Attachments
Framework (22.17 KB, patch)
2006-10-18 14:36 PDT, David Carson
no flags Details | Formatted Diff | Diff
Updated framework (24.95 KB, patch)
2006-10-27 13:21 PDT, David Carson
no flags Details | Formatted Diff | Diff
sessionStorage test page (1.04 KB, application/xhtml+xml)
2006-10-27 13:24 PDT, David Carson
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Carson 2006-10-10 11:55:47 PDT
Firefox 2.0 will have support for this feature and WebKit should support it to.
http://www.mozilla.com/en-US/firefox/2.0/releasenotes/

After discussing with xenon, MacDome and MarvinD on IRC, we decided that the data could be stored in SQLLite.
Comment 1 David Carson 2006-10-18 14:36:11 PDT
Created attachment 11138 [details]
Framework

This patch is just the framework for sessionStorage support.
Comment 2 David Carson 2006-10-27 13:21:55 PDT
Created attachment 11256 [details]
Updated framework

This is mostly working for sessionStorage. It is missing the security checks for accessing the value in StorageItem. 
Missing is support for globalStorage and the StorageEvent
Comment 3 David Carson 2006-10-27 13:24:14 PDT
Created attachment 11257 [details]
sessionStorage test page

Very rough sessionStorage test page to test basic functionality.
When testing, you should be able to reload the page, and still access data stored previously.
Comment 4 Alexey Proskuryakov 2007-01-31 02:27:33 PST
*** Bug 12489 has been marked as a duplicate of this bug. ***
Comment 5 David Kilzer (:ddkilzer) 2008-03-13 11:10:10 PDT
<rdar://problem/5797684>

Comment 6 Brady Eidson 2008-05-07 13:01:25 PDT
Those following recent checkins have noticed that I have now finished implementing this.
SessionStorage has been complete for weeks and as of yesterday LocalStorage was completed.

Listing all of the checkins involved would not be productive, but as of r32942 this is complete.
Comment 7 William J. Edney 2008-09-07 12:15:00 PDT
All -

Note that I just filed bug:

https://bugs.webkit.org/show_bug.cgi?id=20701

showing localStorage not working for file:// or http://localhost URLs.

I've attached a testcase to that bug.

Thanks!

Cheers,

- Bill