Bug 111870 - [Stable][Gtk][1.11.91] Crash in WebKit::FrameLoaderClient::dispatchDidFinishLoading(WebCore::DocumentLoader*, unsigned long)
Summary: [Stable][Gtk][1.11.91] Crash in WebKit::FrameLoaderClient::dispatchDidFinishL...
Status: RESOLVED DUPLICATE of bug 110588
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-08 10:24 PST by Priit Laes (IRC: plaes)
Modified: 2013-03-08 10:36 PST (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Priit Laes (IRC: plaes) 2013-03-08 10:24:05 PST
Webkit-gtk-1.11.91
Epiphany-3.7.91

Reproducing:
1. Go to http://www.wired.com/underwire/2013/03/fake-ufo-video/
2. middle-click twice on the "UFO Over Santa Clarita VFX Breakdown" link in the paragraph just after the video.
3. Crash

[snip]
#0  __strcmp_ssse3 () at ../sysdeps/x86_64/multiarch/../strcmp.S:213
#1  0x00007ffff2465079 in g_str_equal (v1=<optimized out>, v2=<optimized out>)
    at ghash.c:1706
#2  0x00007ffff55955af in WebKit::FrameLoaderClient::dispatchDidFinishLoading(WebCore::DocumentLoader*, unsigned long) () from /usr/lib64/libwebkitgtk-3.0.so.0
#3  0x00007ffff5be8fa2 in WebCore::ResourceLoadNotifier::dispatchDidFinishLoading(WebCore::DocumentLoader*, unsigned long, double) ()
   from /usr/lib64/libwebkitgtk-3.0.so.0
#4  0x00007ffff5be48f9 in WebCore::ResourceLoader::didFinishLoading(double) ()
   from /usr/lib64/libwebkitgtk-3.0.so.0
#5  0x00007ffff5bee324 in WebCore::SubresourceLoader::didFinishLoading(double)
    () from /usr/lib64/libwebkitgtk-3.0.so.0
#6  0x00007ffff63835c8 in WebCore::readCallback(_GObject*, _GAsyncResult*, void*) () from /usr/lib64/libwebkitgtk-3.0.so.0
#7  0x00007ffff2a05b55 in async_ready_callback_wrapper (
    source_object=0x24f94a0, res=0x1f620f0, user_data=0x7fff45cabb28)
    at ginputstream.c:530
#8  0x00007ffff2a29b53 in g_task_return_now (task=0x1f620f0) at gtask.c:1105
#9  0x00007ffff2a29b79 in complete_in_idle_cb (task=0x1f620f0) at gtask.c:1114
#10 0x00007ffff2474ca3 in g_main_dispatch (context=0x716080) at gmain.c:3054
#11 g_main_context_dispatch (context=0x716080) at gmain.c:3630
#12 0x00007ffff2474fe8 in g_main_context_iterate (dispatch=1, 
    block=<optimized out>, context=0x716080, self=<optimized out>)
---Type <return> to continue, or q <return> to quit---
    at gmain.c:3701
#13 g_main_context_iterate (context=0x716080, block=<optimized out>, 
    dispatch=1, self=<optimized out>) at gmain.c:3638
#14 0x00007ffff24750a4 in g_main_context_iteration (context=0x716080, 
    may_block=1) at gmain.c:3762
#15 0x00007ffff2a4bd74 in g_application_run (application=0x8b0000, 
    argc=<optimized out>, argc@entry=1, argv=argv@entry=0x7fffffffddf8)
    at gapplication.c:1620
#16 0x0000000000434294 in main (argc=1, argv=0x7fffffffddf8) at ephy-main.c:488
[/snip]
Comment 1 Martin Robinson 2013-03-08 10:36:23 PST
Looks like Carlos just didn't merge http://trac.webkit.org/changeset/144055

*** This bug has been marked as a duplicate of bug 110588 ***