Bug 111674 - ConvertThis should be turned into Identity based on predictions in Fixup, rather than based on proofs in ConstantFolding
Summary: ConvertThis should be turned into Identity based on predictions in Fixup, rat...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Filip Pizlo
URL:
Keywords:
: 110395 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-03-06 20:34 PST by Filip Pizlo
Modified: 2013-03-07 01:07 PST (History)
7 users (show)

See Also:


Attachments
the patch (17.31 KB, patch)
2013-03-06 21:14 PST, Filip Pizlo
oliver: review+
Details | Formatted Diff | Diff
patch for landing (86.43 KB, patch)
2013-03-06 23:54 PST, Filip Pizlo
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Filip Pizlo 2013-03-06 20:34:21 PST
Patch forthcoming.
Comment 1 Filip Pizlo 2013-03-06 21:14:59 PST
Created attachment 191911 [details]
the patch
Comment 2 Filip Pizlo 2013-03-06 21:18:04 PST
*** Bug 110395 has been marked as a duplicate of this bug. ***
Comment 3 Oliver Hunt 2013-03-06 21:42:17 PST
Comment on attachment 191911 [details]
the patch

Can you add some test cases to ensure we get the correct conversion behaviour?

Reviewed from my iPhone
Comment 4 Filip Pizlo 2013-03-06 21:44:45 PST
(In reply to comment #3)
> (From update of attachment 191911 [details])
> Can you add some test cases to ensure we get the correct conversion behaviour?
> 
> Reviewed from my iPhone

I think LayoutTests/fast/js/dfg-convert-this-dom-window has good coverage for this already.

I'll try to add OSR exit test cases though.
Comment 5 Filip Pizlo 2013-03-06 23:54:46 PST
Created attachment 191935 [details]
patch for landing
Comment 6 Filip Pizlo 2013-03-07 01:07:36 PST
Landed in http://trac.webkit.org/changeset/145052