Bug 111486 - Add V8Document.h include when the V8 code generator creates a toV8(Document*) call.
Summary: Add V8Document.h include when the V8 code generator creates a toV8(Document*)...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Aaron Colwell
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-05 14:45 PST by Aaron Colwell
Modified: 2013-03-05 16:21 PST (History)
4 users (show)

See Also:


Attachments
Patch (1.41 KB, patch)
2013-03-05 14:46 PST, Aaron Colwell
no flags Details | Formatted Diff | Diff
Fix run-bindings-tests expectations (2.05 KB, patch)
2013-03-05 15:33 PST, Aaron Colwell
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Aaron Colwell 2013-03-05 14:45:04 PST
Add V8Document.h include when the V8 code generator creates a toV8(Document*) call.
Comment 1 Aaron Colwell 2013-03-05 14:46:00 PST
Created attachment 191570 [details]
Patch
Comment 2 Aaron Colwell 2013-03-05 14:54:43 PST
It's not obvious from the patch context, but the line below the "Document* document = currentDocument(BindingState::instance());" line uses the Document* version of toV8() declared in V8Document.h. 

While tracking down a crash that led me to move the ActiveDOMObject annotation from HTMLAudioElement.idl to HTMLMediaElement.idl, I discovered a build breaker caused by this missing include.
Comment 3 Adam Barth 2013-03-05 15:19:37 PST
Please run-bindings-tests before landing.
Comment 4 Aaron Colwell 2013-03-05 15:33:03 PST
Created attachment 191585 [details]
Fix run-bindings-tests expectations
Comment 5 WebKit Review Bot 2013-03-05 16:21:46 PST
Comment on attachment 191585 [details]
Fix run-bindings-tests expectations

Clearing flags on attachment: 191585

Committed r144846: <http://trac.webkit.org/changeset/144846>
Comment 6 WebKit Review Bot 2013-03-05 16:21:49 PST
All reviewed patches have been landed.  Closing bug.