Bug 111485 - Dashboard cleanup: move string utilities into their own namespace.
Summary: Dashboard cleanup: move string utilities into their own namespace.
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Julie Parent
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-05 14:42 PST by Julie Parent
Modified: 2013-03-05 16:20 PST (History)
5 users (show)

See Also:


Attachments
Patch (24.30 KB, patch)
2013-03-05 14:49 PST, Julie Parent
no flags Details | Formatted Diff | Diff
Patch (24.05 KB, patch)
2013-03-05 15:32 PST, Julie Parent
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Julie Parent 2013-03-05 14:42:05 PST
Dashboard cleanup: move string utilities into their own namespace.
Comment 1 Julie Parent 2013-03-05 14:49:55 PST
Created attachment 191572 [details]
Patch
Comment 2 Ojan Vafai 2013-03-05 15:10:50 PST
Comment on attachment 191572 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=191572&action=review

> Tools/TestResultServer/static-dashboards/string.js:30
> +var stringUtil = stringUtil || {};

How about s/stringUtil/string?
Comment 3 Julie Parent 2013-03-05 15:13:51 PST
Comment on attachment 191572 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=191572&action=review

>> Tools/TestResultServer/static-dashboards/string.js:30
>> +var stringUtil = stringUtil || {};
> 
> How about s/stringUtil/string?

I originally used string, but I thought that was confusing because there is the built-in String.
Comment 4 Ojan Vafai 2013-03-05 15:20:41 PST
Util is a useless word. I don't think there's much threat of people confusing string.contains with String.contains. 

I'd rather have something like base.string than stringUtil. My preference is still for just plain string though.
Comment 5 Julie Parent 2013-03-05 15:32:57 PST
Created attachment 191584 [details]
Patch
Comment 6 Julie Parent 2013-03-05 15:33:31 PST
(In reply to comment #4)
> Util is a useless word. I don't think there's much threat of people confusing string.contains with String.contains. 
> 
> I'd rather have something like base.string than stringUtil. My preference is still for just plain string though.

Changed to string.
Comment 7 WebKit Review Bot 2013-03-05 16:20:55 PST
Comment on attachment 191584 [details]
Patch

Clearing flags on attachment: 191584

Committed r144845: <http://trac.webkit.org/changeset/144845>
Comment 8 WebKit Review Bot 2013-03-05 16:20:59 PST
All reviewed patches have been landed.  Closing bug.