Bug 111481 - Do not add CSSPropertyBorderImage shorthand part of the property list when parsing CSS border property
Summary: Do not add CSSPropertyBorderImage shorthand part of the property list when pa...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Alexis Menard (darktears)
URL:
Keywords: WebExposed
Depends on:
Blocks: 111505
  Show dependency treegraph
 
Reported: 2013-03-05 14:12 PST by Alexis Menard (darktears)
Modified: 2013-03-06 04:17 PST (History)
12 users (show)

See Also:


Attachments
Patch (2.08 KB, patch)
2013-03-05 14:21 PST, Alexis Menard (darktears)
no flags Details | Formatted Diff | Diff
Patch for landing (5.55 KB, patch)
2013-03-06 03:53 PST, Alexis Menard (darktears)
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alexis Menard (darktears) 2013-03-05 14:12:33 PST
Do not add CSSPropertyBorderImage shorthand part of the property list when parsing CSS border property
Comment 1 Alexis Menard (darktears) 2013-03-05 14:21:32 PST
Created attachment 191565 [details]
Patch
Comment 2 WebKit Review Bot 2013-03-05 15:29:05 PST
Comment on attachment 191565 [details]
Patch

Attachment 191565 [details] did not pass chromium-ews (chromium-xvfb):
Output: http://webkit-commit-queue.appspot.com/results/17074038

New failing tests:
inspector/styles/styles-new-API.html
Comment 3 Julien Chaffraix 2013-03-05 15:41:59 PST
Comment on attachment 191565 [details]
Patch

r=me, the inspector/styles/styles-new-API.html diff is real: it's caused by a couple of border-image now being expanded. Here is the diff: https://gist.github.com/anonymous/5095388
Comment 4 Build Bot 2013-03-05 16:53:40 PST
Comment on attachment 191565 [details]
Patch

Attachment 191565 [details] did not pass mac-wk2-ews (mac-wk2):
Output: http://webkit-commit-queue.appspot.com/results/17004049

New failing tests:
inspector/styles/styles-new-API.html
Comment 5 Alexis Menard (darktears) 2013-03-06 03:53:53 PST
Created attachment 191709 [details]
Patch for landing
Comment 6 WebKit Review Bot 2013-03-06 04:17:00 PST
Comment on attachment 191709 [details]
Patch for landing

Clearing flags on attachment: 191709

Committed r144908: <http://trac.webkit.org/changeset/144908>
Comment 7 WebKit Review Bot 2013-03-06 04:17:04 PST
All reviewed patches have been landed.  Closing bug.