Bug 111470 - Implement CSS display-box property
Summary: Implement CSS display-box property
Status: NEW
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Elliott Sprehn
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-05 12:57 PST by Elliott Sprehn
Modified: 2017-07-18 08:29 PDT (History)
7 users (show)

See Also:


Attachments
WIP (16.74 KB, patch)
2013-03-05 12:57 PST, Elliott Sprehn
ojan: review-
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Elliott Sprehn 2013-03-05 12:57:33 PST
Implement CSS display-box property
Comment 1 Elliott Sprehn 2013-03-05 12:57:54 PST
Created attachment 191543 [details]
WIP
Comment 2 WebKit Review Bot 2013-03-05 13:04:28 PST
Attachment 191543 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/WebCore/ChangeLog', u'Source/WebCore/css/CSSComputedStyleDeclaration.cpp', u'Source/WebCore/css/CSSParser.cpp', u'Source/WebCore/css/CSSPrimitiveValueMappings.h', u'Source/WebCore/css/CSSProperty.cpp', u'Source/WebCore/css/CSSPropertyNames.in', u'Source/WebCore/css/StyleBuilder.cpp', u'Source/WebCore/dom/Node.cpp', u'Source/WebCore/rendering/style/RenderStyle.cpp', u'Source/WebCore/rendering/style/RenderStyle.h', u'Source/WebCore/rendering/style/RenderStyleConstants.h']" exit_code: 1
Source/WebCore/rendering/style/RenderStyle.h:242:  _actualDisplay is incorrectly named. Don't use underscores in your identifier names.  [readability/naming/underscores] [4]
Source/WebCore/rendering/style/RenderStyle.h:257:  _displayBox is incorrectly named. Don't use underscores in your identifier names.  [readability/naming/underscores] [4]
Total errors found: 2 in 11 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Ojan Vafai 2013-03-05 19:39:39 PST
Comment on attachment 191543 [details]
WIP

I think we need to wait for the www-style discussion to be resolved before we move forward here.

Some thoughts on this patch as is:
-I don't like changing "effective" to "actual". I feel like effective is more clear (i.e. actual as opposed to what? fake?).
-Needs tests. Some cases that need to be tested: display:none;display-box:none, display:flex;display-box:none, display:none;display-box:normal, display:flex;display-box:normal
Comment 4 Tab Atkins 2013-03-06 14:43:19 PST
(In reply to comment #3)
> I think we need to wait for the www-style discussion to be resolved before we move forward here.

The WG didn't object to the change (moving the property from being a display sub-property to being an independent property), so all we're blocked on now is the name. :/