Bug 110869 - [WK2][GTK] REGRESSION (r143463): unit test failure in WebKit2APITests/TestContextMenu
Summary: [WK2][GTK] REGRESSION (r143463): unit test failure in WebKit2APITests/TestCon...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-26 03:55 PST by Manuel Rego Casasnovas
Modified: 2013-02-26 10:31 PST (History)
5 users (show)

See Also:


Attachments
Patch (2.94 KB, patch)
2013-02-26 04:09 PST, Manuel Rego Casasnovas
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Manuel Rego Casasnovas 2013-02-26 03:55:55 PST
A regression was introduced at r143463 with the following unit test failing:

TEST: ./Tools/gtk/../Scripts/../../WebKitBuild/Release/Programs/WebKit2APITests/TestContextMenu... (pid=26027)

  /webkit2/WebKitWebView/default-menu:                                 

(WebKitWebProcess:26032): Gtk-WARNING **: Invalid icon size 16

**

ERROR:../../Source/WebKit2/UIProcess/API/gtk/tests/TestContextMenu.cpp:265:virtual bool ContextMenuDefaultTest::contextMenu(WebKitContextMenu*, GdkEvent*, WebKitHitTestResult*): assertion failed: (webkit_hit_test_result_context_is_link(hitTestResult))

FAIL

The cause: http://trac.webkit.org/changeset/143463

The reason is that the new media controls needs more space than a video tag of 10x10.
Comment 1 Manuel Rego Casasnovas 2013-02-26 04:09:02 PST
Created attachment 190257 [details]
Patch
Comment 2 WebKit Review Bot 2013-02-26 04:11:41 PST
Thanks for the patch. If this patch contains new public API please make sure it follows the guidelines for new WebKit2 GTK+ API. See http://trac.webkit.org/wiki/WebKitGTK/AddingNewWebKit2API
Comment 3 WebKit Review Bot 2013-02-26 09:23:02 PST
Comment on attachment 190257 [details]
Patch

Rejecting attachment 190257 [details] from commit-queue.

New failing tests:
fast/js/dfg-inline-resolve.html
Full output: http://webkit-commit-queue.appspot.com/results/16778189
Comment 4 WebKit Review Bot 2013-02-26 10:31:20 PST
Comment on attachment 190257 [details]
Patch

Clearing flags on attachment: 190257

Committed r144070: <http://trac.webkit.org/changeset/144070>
Comment 5 WebKit Review Bot 2013-02-26 10:31:23 PST
All reviewed patches have been landed.  Closing bug.