Bug 11071 - CSS property visibility: collapse; when applied to table columns does nothing
Summary: CSS property visibility: collapse; when applied to table columns does nothing
Status: RESOLVED DUPLICATE of bug 8735
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: 419.x
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-09-27 15:18 PDT by Robert Burns
Modified: 2008-01-22 21:07 PST (History)
3 users (show)

See Also:


Attachments
Sample HTML showing "visibility:collapse" flaw for columns. (300 bytes, text/html)
2008-01-22 15:51 PST, Quinn Taylor
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Burns 2006-09-27 15:18:39 PDT
When the visiblity property is set to collapsed for table columns WebKit renders it as if visibility is set to visible.

See quirksmode http://www.quirksmode.org/css/columns.html#%23visibility
Comment 1 Mark Rowe (bdash) 2006-09-28 03:05:46 PDT
This is likely related to bug 8735, which deals with "visibility: collapse" on table rows being treated the same as "visibility: hidden".
Comment 2 Quinn Taylor 2008-01-22 15:51:33 PST
Created attachment 18607 [details]
Sample HTML showing "visibility:collapse" flaw for columns.

This document display a "telephone pad" arrangement of numbers. The CSS should cause the middle column to disappear, and does in Firefox, etc.
Comment 3 Quinn Taylor 2008-01-22 15:57:41 PST
A fix to this bug would provide a lot of flexibility to web pages, without specifying a class for each table cell in a column that should be invisible. For example, auto-generated HTML pages with columns containing something like image links (which are useless when printed) could be hidden with CSS for print media.

This bug is still present in Safari 3 that ships with Leopard, as well as the latest nightly build (r29711).
Comment 4 mitz 2008-01-22 21:07:26 PST

*** This bug has been marked as a duplicate of 8735 ***